Subject: Clarification Needed on Postgresql License Requirement for Hybrid Environment Cluster Configuration

From: Prasanna Chavan <[email-masked]>
Date: Mon, 6 May 2024 08:15:13 +0000

Hi,

I hope this email finds you well. I am reaching out to seek clarification on a matter regarding the configuration of a cluster in a hybrid environment.
Specifically, I am wondering whether we require a PostgreSQL license for setting up a cluster in such an environment. Could you kindly provide some guidance or clarification on this matter?
Your expertise and insights on this issue would be greatly appreciated. Thank you in advance for your assistance.
Looking forward to your prompt response.
Best regards,
Prasanna

---

From: Alvaro Herrera <[email-masked]>
Date: Mon, 6 May 2024 14:09:30 +0200

Hello,

On 2024-May-06, Prasanna Chavan wrote:

> I hope this email finds you well. I am reaching out to seek
> clarification on a matter regarding the configuration of a cluster in
> a hybrid environment.
> Specifically, I am wondering whether we require a PostgreSQL license
> for setting up a cluster in such an environment. Could you kindly
> provide some guidance or clarification on this matter?

Yes, you require a license.  However, luckily for you, the license is
provided for any purpose, without fee, and without a written agreement.
The COPYRIGHT file in the source distribution contains the details.
You can use the software standalone or in cluster configuration, as you
see fit.  In short, you don't need to worry about it.

However, this doesn't necessarily apply to other software packages
derived from PostgreSQL itself, or those that work in conjunction with
it, such as Postgres extensions, admin interfaces, GUIs, monitoring
packages, etc.  You'll have to seek clarification on each such software
package that you intend to use.

-- 
Álvaro Herrera               48°01'N 7°57'E  —  https://www.EnterpriseDB.com/
"I dream about dreams about dreams", sang the nightingale
under the pale moon (Sandman)