Subject: Re: Cannot turn track_counts on

From: Daniel Gustafsson <[email-masked]>
Date: Wed, 16 Apr 2025 17:03:46 +0200

> On 16 Apr 2025, at 16:53, Tom Lane <[email-masked]> wrote:
> 
> Anton Shepelev <[email-masked]> writes:
>> pg_settings shows:
> 
>>  name    | track_counts
>>  setting | on
>>  source  | override
> 
>> What does 'override' mean in the 'source' column?  How can I
>> find where in the system this setting is overridden?
> 
> I am fairly certain that there is nothing in core Postgres that
> would do that.  PGC_S_OVERRIDE is used to lock down the values
> of certain variables that shouldn't be allowed to change, but
> track_counts surely isn't one of those.  And a quick grep
> through the code finds nothing applying PGC_S_OVERRIDE to it.
> 
> What extensions do you have installed?

Also, is this by any chance a managed instance like Amazon RDS or Azure, or is
it a local database under your control?

--
Daniel Gustafsson

---

From: Anton Shepelev <[email-masked]>
Date: Wed, 16 Apr 2025 19:34:07 +0300

Daniel Gustafsson:

> Also, is this by any chance a managed instance like Amazon
> RDS or Azure, or is it a local database under your
> control?

It is a normal installation on a Linux machine, and my
company has full root access to it over SSH.  Because of
strict security measures, however, only a certain employee
can connect, and only form a certain client machine.  I will
answer the other questions as soon as I am able to arrange a
session at his PC to perform the recommended diagnostic
queries.

-- 
()  ascii ribbon campaign -- against html e-mail
/\  www.asciiribbon.org   -- against proprietary attachments

---

From: Ron Johnson <[email-masked]>
Date: Thu, 17 Apr 2025 08:53:50 -0400

On Thu, Apr 17, 2025 at 5:13 AM Anton Shepelev <[email-masked]> wrote:

> can connect,

Better hope he doesn't get hit by a bus, decide to quit, etc.

> and only form a certain client machine.
>

And that specific client machine doesn't break, become corrupted during a
Windows Update, get malware, etc.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!