Subject: Re: What are best practices wrt passwords?

From: Achilleas Mantzios <[email-masked]>
Date: Wed, 16 Oct 2024 21:29:20 +0300

Στις 16/10/24 19:47, ο/η Tom Lane έγραψε:
> Bruce Momjian <[email-masked]> writes:
>> On Wed, Oct 16, 2024 at 06:16:57PM +0200, [email-masked] wrote:
>>> `ps auxe` shows all processes with their environments, no?
>> I think that only shows for super-user.
> I believe it depends on your platform --- some BSDen are pretty
> permissive about this, if memory serves.  On a Linux box it seems

As of FreeBSD smadevnu 14.1-RELEASE-p5 , only the user and root can view 
the env, such as PGPASSWORD of a user. Other users can't.

> to work for processes owned by yourself even if you're not superuser.
>
> 			regards, tom lane
>
>

---

From: Tom Lane <[email-masked]>
Date: Wed, 16 Oct 2024 14:47:05 -0400

> the env, such as PGPASSWORD of a user. Other users can't.

NetBSD 10 seems to behave the same.  I don't have a recent OpenBSD
installation to try.

			regards, tom lane