Subject: Re: Customize psql prompt to show current_role

From: Dominique Devienne <[email-masked]>
Date: Mon, 23 Sep 2024 14:34:39 +0200

On Mon, Sep 23, 2024 at 2:22 PM Asad Ali <[email-masked]> wrote:
> There is no direct prompt escape sequence like %n for displaying the current_role in the psql prompt.
> However, you can work around this by using a \set command to define a custom prompt that includes the result of current_role.

Hi Ali. Doesn't seem to be working for me. Did I do something wrong? --DD

```
D:\>psql service=pau16
psql (17beta3, server 16.1)
Type "help" for help.

ddevienne=> \set current_role 'SELECT current_role;'
ddevienne=> \set PROMPT1 '%n@%/ (%`current_role`)=%# '
'current_role' is not recognized as an internal or external command,
operable program or batch file.
ddevienne@ddevienne ()=> select 1;
...
'current_role' is not recognized as an internal or external command,
operable program or batch file.
ddevienne@ddevienne ()=>
```

---

From: [email-masked]
Date: Mon, 23 Sep 2024 14:49:15 +0200 (CEST)

----- Mail original -----
> De: "Dominique Devienne" <[email-masked]>
> À: "Asad Ali" <[email-masked]>
> Cc: [email-masked]
> Envoyé: Lundi 23 Septembre 2024 14:34:39
> Objet: Re: Customize psql prompt to show current_role

>> However, you can work around this by using a \set command to define a custom
>> prompt that includes the result of current_role.
> 

Hello Dominique,

I will use psql \gset command for this

Regards
Gilles