Subject: RE: error “server process was terminated by signal 11: Segmentation fault” running pg_create_logical_replication_slot using pgoutput plugin

From: "Hayato Kuroda (Fujitsu)" <[email-masked]>
Date: Fri, 11 Jul 2025 02:09:41 +0000

Dear Abrahim

> The Citus extension package is installed, but it is not preload on shared_preload_libraries
> and citus extesion is not created.

It is possible that a shared library is loaded even if shared_preload is not set
and CREATE EXTENSION is not executed. Per my understanding the specified plugin
name would be searched by the same rule as other libraries. See [1].

Another example is 'test_decoding'. It is a sample plugin which postgres-core
includes. Anyone can use the plugin via SQL function. CREATE EXTENSION is not needed.

```
postgres=# SELECT pg_create_logical_replication_slot('slot', 'test_decoding');
 pg_create_logical_replication_slot 
------------------------------------
 (slot,0/1829CE0)
(1 row)
```

> I will create a new container without Citus extension package ...

Yeah, it is quite helpful to understand the issue correctly. Thanks for working on it.

[1]: https://www.postgresql.org/docs/devel/xfunc-c.html#XFUNC-C-DYNLOAD

Best regards,
Hayato Kuroda
FUJITSU LIMITED

---

From: abrahim abrahao <[email-masked]>
Date: Fri, 11 Jul 2025 21:55:51 +0000 (UTC)

Hi Hayato and Shlok, I confirmed that it is related of Citus, everytrhing worked after remove the Citus instalation from the docker image.
I did not added stack trace yet on the new instalation. It seems that the present Citus installation was done in an unusual way. I will work to figure out a better way to install it.

 Thanks for your help, I appreciate it.

    On Thursday, July 10, 2025 at 08:10:18 p.m. MDT, Hayato Kuroda (Fujitsu) <[email-masked]> wrote:  
 
 Dear Abrahim

```

Best regards,
Hayato Kuroda
FUJITSU LIMITED

---

From: "Hayato Kuroda (Fujitsu)" <[email-masked]>
Date: Tue, 15 Jul 2025 03:09:53 +0000

Dear Abrahim,

> Hi Hayato and Shlok, I confirmed that it is related of Citus, everytrhing worked
> after remove the Citus instalation from the docker image.

Thanks for the confirmation. I also feel that the issue is related with Citus. I recommend
to report the Citus's community [1] to solve the issue.

[1]: https://github.com/citusdata/citus

Best regards,
Hayato Kuroda
FUJITSU LIMITED