Subject: Re: VACUUM on temp table blocks VACUUM on another...

From: Adrian Klaver <[email-masked]>
Date: Thu, 1 Aug 2024 12:25:17 -0700

On 8/1/24 12:12, Tom Lane wrote:
> Jim Vanns <[email-masked]> writes:
>> I have two sessions, each creating a temporary table of the same name -
>> 'foobar'. Why would a vacuum of 'foobar' from one session block the vacuum
>> of 'foobar' in the other session?
> 
> That's fairly hard to believe.  Can you provide a self-contained test
> case?

Would also be nice to know what version of Postgres and where you are 
running the server?

> 			regards, tom lane

-- 
Adrian Klaver
[email-masked]

---

From: Jim Vanns <[email-masked]>
Date: Thu, 1 Aug 2024 20:58:06 +0100

Sorry, PG15.

Jim

-- 
Jim Vanns
Principal Production Engineer
Industrial Light & Magic, London

---

From: Ron Johnson <[email-masked]>
Date: Thu, 1 Aug 2024 17:26:40 -0400

PG 15.0 or 15.7?

---

From: Jim Vanns <[email-masked]>
Date: Thu, 1 Aug 2024 23:13:43 +0100

PG 15.4

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 1 Aug 2024 15:31:43 -0700

> PG 15.4

Community edition or some variant?

---

From: Jim Vanns <[email-masked]>
Date: Fri, 2 Aug 2024 08:38:42 +0100

Official PGDB RPM build for Centos 7.9