Subject: Get info about the index

From: Igor Korot <[email-masked]>
Date: Sat, 26 Jul 2025 10:00:05 -0500

Hi, ALL,
Is there a better place to get the info about the index other than
https://www.postgresql.org/docs/current/view-pg-indexes.html

That guy has a full blown CREATE INDEX command and I will need to
parse it to get the info I need.

Thank you.

---

From: Adrian Klaver <[email-masked]>
Date: Sat, 26 Jul 2025 08:15:11 -0700

> parse it to get the info I need.

FYI,

pg_class:

https://www.postgresql.org/docs/current/catalog-pg-class.html

and pg_attribute:

https://www.postgresql.org/docs/current/catalog-pg-attribute.html

also have index information.

-- 
Adrian Klaver
[email-masked]

---

From: Tom Lane <[email-masked]>
Date: Sat, 26 Jul 2025 11:19:00 -0400

> also have index information.

pg_index is the real source of truth here.

			regards, tom lane