Subject: Where is my app installed?

From: Arbol One <[email-masked]>
Date: Thu, 22 Aug 2024 20:36:31 -0400

After installing PostgreSQL on my Debian-12 machine, I typed 'postgres 
--version' and got this msg:
*bash: postgres: command not found*

'psql --version', however, does work and gives me this message :

*psql (PostgreSQL) 16.3 (Debian 16.3-1.pgdg120+1)*

Obviously postgres is not in the path, but I don't know where the 
'apt-get' installed it or why it did not add it to the path.

Is there a way I can locate the installation directory?

Thank in advance.

-- 
*/ArbolOne.ca/* Using Fire Fox and Thunderbird. ArbolOne is composed of 
students and volunteers dedicated to providing free services to 
charitable organizations. ArbolOne on Java Development is in progress [ í ]

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 22 Aug 2024 17:49:53 -0700

> Is there a way I can locate the installation directory?

As to where the  postgres command is:

ls -al /usr/lib/postgresql/16/bin/

[...]
-rwxr-xr-x 1 root root 10338808 Aug  7 06:13 postgres*
[...]

Why do you want to use postgres directly?

-- 
Adrian Klaver
[email-masked]

---

From: Alan Hodgson <[email-masked]>
Date: Thu, 22 Aug 2024 17:53:10 -0700

On Thu, 2024-08-22 at 20:36 -0400, Arbol One wrote:
>  
> After installing PostgreSQL on my Debian-12 machine, I typed
> 'postgres --version' and got this msg:
>  bash: postgres: command not found
>  
> psql (PostgreSQL) 16.3 (Debian 16.3-1.pgdg120+1)
>  

find / -name postgres

or

dpkg-query -L postgresql-16 | grep 'bin/postgres$'

You wouldn't normally invoke the server from the command line, so it
doesn't need to be in anyone's path.

---

From: Arbol One <[email-masked]>
Date: Fri, 23 Aug 2024 07:55:02 -0400

Thanks everyone, the issue was resolved.