Subject: Re: Transaction issue

From: Rich Shepard <[email-masked]>
Date: Wed, 19 Jun 2024 11:36:49 -0700 (PDT)

On Wed, 19 Jun 2024, Adrian Klaver wrote:

> Is this being done in a script fed to psql?

Adrian,

Yes. At the psql prompt I use the \i <filename> command to run the script.

Rich

---

From: Adrian Klaver <[email-masked]>
Date: Wed, 19 Jun 2024 11:40:29 -0700

> Yes. At the psql prompt I use the \i <filename> command to run the script.

Are there transaction statements e.g. BEGIN;, COMMIT; in the script?

-- 
Adrian Klaver
[email-masked]

---

From: Rich Shepard <[email-masked]>
Date: Wed, 19 Jun 2024 12:40:10 -0700 (PDT)

Adrian,

Yes, each script has BEGIN; on line 1.

Rich

---

From: Adrian Klaver <[email-masked]>
Date: Wed, 19 Jun 2024 13:10:02 -0700

> Yes, each script has BEGIN; on line 1.

Does it have a COMMIT; at the end?

At this point I think you need to create a simple test case where:

1) You have script with
BEGIN;
<A line that contains the syntax error>
COMMIT;

2) In psql do \i <the_script>

3) Do what you did before.

Shows us the content of the steps in your reply.

---

From: Rich Shepard <[email-masked]>
Date: Wed, 19 Jun 2024 13:13:31 -0700 (PDT)

Adrian,

No. I won't commit until I see the results are as intended.

> At this point I think you need to create a simple test case where:

I killed the psql process and restarted it to allow me to work on other
issues right now; will run a test when I again get that error.

Thanks,

Rich