Subject: untracked child process (PID XXXXX) exited with exit code 120

From: Torsten Krah <[email-masked]>
Date: Thu, 07 May 2026 19:37:38 +0200

Hi,

I am running PostgreSQL 18.3 (Debian 18.3-1.pgdg13+1) (docker image)
and found this in my database logs the other day:

2026-05-07 18:39:13.947 CEST [1] LOG:  untracked child process (PID 33254) exited with exit code 120
2026-05-07 18:39:13.947 CEST [1] LOG:  terminating any other active server processes
2026-05-07 18:39:14.077 CEST [1] LOG:  all server processes terminated; reinitializing

Anyone an idea about that untracked child process and what exit code
120 of that process would mean / want to tell me?

Thanks.

Torsten

PS: I used https://www.postgresql.org/search/ , but was unsuccessful so
far to get any hints on this, but maybe I just did not find the correct
question yet ;).

---

From: Alexander Kukushkin <[email-masked]>
Date: Thu, 7 May 2026 19:51:27 +0200

My guess would be that the postmaster in your container is running with
PID=1.
The unexpected process was probably started by docker entrypoint before it
did exec postgres [...].
As a result, this subprocess became a direct child of the postmaster and we
got the problem.

The most common solution is to avoid running postmaster with PID=1.
There are two options available:
1. dumb-init
2. start container using "docker run --init [...]"

-- 
Regards,
--
Alexander Kukushkin