Subject: RE: postgresql-17.0-1 Application - silent installation Issue

From: "JOLAPARA Urvi (SAFRAN)" <[email-masked]>
Date: Tue, 12 Nov 2024 06:09:21 +0000

C2 - Confidential

Hello Klaver,

We are using PSADT for creating a script and installing through SCCM.
And when we are installing Through Software center it is throwing error as below:

"There has been an error
error while writing file C:\windows\Temp\postgresql_installer_8b85d458af\temp_check_comspec.bat"

Thanks & Regards,
Urvi Jolapara
[email-masked]

www.safran-group.com

-----Original Message-----
From: Adrian Klaver <[email-masked]> 
Sent: Monday, November 11, 2024 9:49 PM
To: JOLAPARA Urvi (SAFRAN) <[email-masked]>; [email-masked]
Cc: KRISHNAN LINGATHAR Karupaswamy (SAFRAN) <[email-masked]>
Subject: Re: postgresql-17.0-1 Application - silent installation Issue

CAUTION:  This message originated from an outside organization. In case of suspicion, click on "Report to SAFRAN Security" from the Outlook ribbon. 

On 11/10/24 07:11, JOLAPARA Urvi (SAFRAN) wrote:
> C2 - Confidential
> 
> 
> Hello Team,
> 
> I am from Application Packaging team. we have created the package of 
> PostgreSQL 17.0-1 Application.

You are going to need to provide more detail on the package creation process.

> 
> We have used the command line parameter for installation is this : 
> *“postgresql-17.0-1-windows-x64.exe--mode unattended 
> --unattendedmodeui none --optionfile C:\Temp\Install”*
> 
> This is working in English language machine but it is failing in 
> French language machine and throwing below error:

You should provide error messages as text not as image, so folks can run them through a translator if need be.

erreur d'ecriture du fichier -> file write error

according to Google.

> 
> 
> we tried giving permission to this folder, then we have used

Which directory(folder) would that be?

> *“--installer-launage fr”* parameter *“--locale fr”* parameters but

Should that not be --installer-language?

Also shouldn't this:

--locale fr

be?:

--locale fr-FR

> still not working.
> 
> Please assist to resolve the issue asap.
> 
> Thanks & Regards,
> 
> Urvi Jolapara
> 
> [email-masked] <mailto:[email-masked]>
> 
> Image
> 
> *www.safran-group.com* 
> <https://urldefense.com/v3/__http://www.safran-group.com/fr/__;!!P3ITo
> RM6tg!lcu8B2WYC3q9sLuzLhCkS5OgLIQrDrJR_oXes8Pd-fyTKP6hFQEEp-cnYrUJTMFp
> brUMR5UjNRKPgmKfoJ8RWMAgLSunLtYk$ >
> 
> #
> " Ce courriel et les documents qui lui sont joints peuvent contenir 
> des informations confidentielles, être soumis aux règlementations 
> relatives au contrôle des exportations ou ayant un caractère privé. 
> S'ils ne vous sont pas destinés, nous vous signalons qu'il est 
> strictement interdit de les divulguer, de les reproduire ou d'en 
> utiliser de quelque manière que ce soit le contenu. Toute exportation 
> ou réexportation non autorisée est interdite Si ce message vous a été 
> transmis par erreur, merci d'en informer l'expéditeur et de supprimer 
> immédiatement de votre système informatique ce courriel ainsi que tous les documents qui y sont attachés."
> ******
> " This e-mail and any attached documents may contain confidential or 
> proprietary information and may be subject to export control laws and 
> regulations. If you are not the intended recipient, you are notified 
> that any dissemination, copying of this e-mail and any attachments 
> thereto or use of their contents by any means whatsoever is strictly 
> prohibited. Unauthorized export or re-export is prohibited. If you 
> have received this e-mail in error, please advise the sender 
> immediately and delete this e-mail and all attached documents from your computer system."
> #

--
Adrian Klaver
[email-masked]

#
" Ce courriel et les documents qui lui sont joints peuvent contenir des informations confidentielles, être soumis aux règlementations relatives au contrôle des exportations ou ayant un caractère privé. S'ils ne vous sont pas destinés, nous vous signalons qu'il est strictement interdit de les divulguer, de les reproduire ou d'en utiliser de quelque manière que ce soit le contenu. Toute exportation ou réexportation non autorisée est interdite Si ce message vous a été transmis par erreur, merci d'en informer l'expéditeur et de supprimer immédiatement de votre système informatique ce courriel ainsi que tous les documents qui y sont attachés."
******
" This e-mail and any attached documents may contain confidential or proprietary information and may be subject to export control laws and regulations. If you are not the intended recipient, you are notified that any dissemination, copying of this e-mail and any attachments thereto or use of their contents by any means whatsoever is strictly prohibited. Unauthorized export or re-export is prohibited. If you have received this e-mail in error, please advise the sender immediately and delete this e-mail and all attached documents from your computer system."
#

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 12 Nov 2024 08:35:52 -0800

> C2 - Confidential

This is a publicly readable list, the above has no meaning in that context.

> We are using PSADT for creating a script and installing through SCCM.

1) I don't work with Windows so I have no idea what the above
means.

2) You did not answer the rest of the questions I asked in my previous post.

a) "we tried giving permission to this folder, then we have used"

b) ' *“--installer-launage fr”* parameter *“--locale fr”* parameters but 
...'

Also shouldn't this:

--locale fr

be?:

--locale fr-FR

> error while writing file C:\windows\Temp\postgresql_installer_8b85d458af\temp_check_comspec.bat"

I would suggest looking in the Windows system log to see if it provides 
more information for the above error.

---

From: "JOLAPARA Urvi (SAFRAN)" <[email-masked]>
Date: Thu, 14 Nov 2024 09:05:49 +0000

C2 - Confidential

Hello Klaver,

I have added below the log where setup is failing on FR language machine.

Log started 11/14/2024 at 09:04:33
Preferred installation mode : unattended
Trying to init installer in mode unattended
Mode unattended successfully initialized
Setting variable whoami from C:\WINDOWS\System32\whoami 
Script exit code: 0

Script output:
 autorite nt\système

Script stderr:

Could not find registry key HKEY_LOCAL_MACHINE\SOFTWARE\PostgreSQL\Installations\postgresql-x64-17 Base Directory. Setting variable iBaseDirectory to empty value
Could not find registry key HKEY_LOCAL_MACHINE\SOFTWARE\PostgreSQL\Installations\postgresql-x64-17 Branding. Setting variable iBranding to empty value
Could not find registry key HKEY_LOCAL_MACHINE\SOFTWARE\PostgreSQL\Installations\postgresql-x64-17 Version. Setting variable brandingVer to empty value
Could not find registry key HKEY_LOCAL_MACHINE\SOFTWARE\PostgreSQL\Installations\postgresql-x64-17 Shortcuts. Setting variable iShortcut to empty value
[09:04:35] Using branding: PostgreSQL 17
Could not find registry key HKEY_LOCAL_MACHINE\SOFTWARE\PostgreSQL\Installations\postgresql-x64-17 SB_Version. Setting variable sb_version to empty value
Could not find registry key HKEY_LOCAL_MACHINE\SOFTWARE\PostgreSQL\Installations\postgresql-x64-17 pgAdmin_Version. Setting variable pgadmin_version to empty value
Could not find registry key HKEY_LOCAL_MACHINE\SOFTWARE\PostgreSQL\Installations\postgresql-x64-17 CLT_Version. Setting variable clt_version to empty value
Could not find registry key HKEY_LOCAL_MACHINE\SOFTWARE\PostgreSQL\Installations\postgresql-x64-17 Data Directory. Setting variable server_data_dir to empty value
Erreur d'écriture du fichier C:/Windows/Temp/postgresql_installer_ee9259ae9d/temp_check_comspec.bat
Exiting with code 1

The Parameters which you suggested in last mail also not working with PostgresSQL exe.

Please transfer the request who works with windows. We need the solution asap.

Thanks & Regards,
Urvi Jolapara

www.safran-group.com

-----Original Message-----
From: Adrian Klaver <[email-masked]> 
Sent: Tuesday, November 12, 2024 10:06 PM
To: JOLAPARA Urvi (SAFRAN) <[email-masked]>; [email-masked]
Cc: KRISHNAN LINGATHAR Karupaswamy (SAFRAN) <[email-masked]>
Subject: Re: postgresql-17.0-1 Application - silent installation Issue

> We are using PSADT for creating a script and installing through SCCM.

1) I don't work with Windows so I have no idea what the above means.

b) ' *“--installer-launage fr”* parameter *“--locale fr”* parameters but ...'

Also shouldn't this:

--locale fr

be?:

--locale fr-FR

> error while writing file C:\windows\Temp\postgresql_installer_8b85d458af\temp_check_comspec.bat"

I would suggest looking in the Windows system log to see if it provides more information for the above error.

> https://urldefense.com/v3/__http://www.safran-group.com__;!!P3IToRM6tg
> !i7_r9jHMtJfM4PYV1cyvZR9mQYp6lntjOt9T-GA9pRPIUtgmhYYAOML3XIg9yKfkczYXx
> mYTan6MAGcfZ9TX8oUAU_sEIeqE$

#

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 14 Nov 2024 08:45:25 -0800

> Please transfer the request who works with windows. We need the solution asap.

Then you probably need to contact a paid tech support company who deals 
with Windows and Postgres. This is the Postgres mailing list and Windows 
support is not really something you will find here.