Subject: Re: Libpq.dll

From: "[email-masked]" <[email-masked]>
Date: Thu, 7 Aug 2025 12:14:27 +0000 (GMT)

When I say "my Postgres", I mean the Postgres 15.3 that I have installed.

How about 32-bit lib.dlls? I downloaded them from Google, placed them in my executable folder and in the Bin and Lib folders of my Postgres 15.3, and then extracted the package into the folders.

The link where I downloaded the 32-bit lib.dlls was this:

https://ftp.postgresql.org/pub/odbc/versions.old/dll/psqlodbc_15_00_0000-x64.zip

I I believe so, it's a mix of 32-bit and 64-bit libraries. I just can't figure out how to fix it, since I already placed the 32-bit libraries in the Postgres Lib and Bin folders.

On ago 6 2025, at 5:02 pm, Adrian Klaver <[email-masked]> wrote:

On 8/6/25 11:24, [email-masked] wrote:
>
>
> The executable's libpq is 32-bit, and its dependencies are correct and
> on the same architecture. In my Postgres, libpq was on a 64-bit

You need to give more details on what '... my Postgres ...' is?

Did you download it as package or did you build it?

In either case what was the source?

> architecture, so I downloaded the 32-bit libdll, and the error still
> persisted.
>
> c)"Error Message: Client-Library
> libpq.dll found but could not be loaded. Check compile-target and
> library compatibility!"

Looks like you are mixing 32/64 bit libraries.

--
Adrian Klaver
[email-masked]

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 7 Aug 2025 09:03:58 -0700

On 8/7/25 05:14, [email-masked] wrote:
> How about 32-bit lib.dlls? I downloaded them from Google, placed them in 
> my executable folder and in the Bin and Lib folders of my Postgres 15.3, 
> and then extracted the package into the folders.
> 
> https://ftp.postgresql.org/pub/odbc/versions.old/dll/ 
> psqlodbc_15_00_0000-x64.zip <https://ftp.postgresql.org/pub/odbc/ 
> versions.old/dll/psqlodbc_15_00_0000-x64.zip>
> 
> I I believe so, it's a mix of 32-bit and 64-bit libraries. I just can't 
> figure out how to fix it, since I already placed the 32-bit libraries in 
> the Postgres Lib and Bin folders.

I would say the chances of this working, given the information provided, 
is slim to none. From what I see you are trying to compile a 32 bit 
executable on a 64 bit platform using miscellaneous files found on the 
Internet.

Per a previous post of mine, steps to getting some direction on this 
will need at minimum:

b) The configuration and compilation steps you took.

c) The complete error message.

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 8 Aug 2025 12:55:52 +0000 (GMT)

I managed to solve it now, it was just a connection error in one of the components of my Delphi, I just deleted it and put it back in 😭

but thank you all very much for your help

On ago 7 2025, at 1:03 pm, Adrian Klaver <[email-masked]> wrote: