Subject: Get version info

From: Igor Korot <[email-masked]>
Date: Sun, 5 Jul 2026 01:32:31 -0500

Hi, ALL,
Google recommends using pg-config.

However, some distro prefer to use pkg-config and don't even include
local configuration file.

Is this file located everywhere and if not - how do I check it inside
configure.ac?

Thank you.

---

From: rob stone <[email-masked]>
Date: Sun, 05 Jul 2026 18:18:14 +1000

> Is this file located everywhere and if not - how do I check it inside

See chapter 9.27.11, not Mr. Google.

select version();

PostgreSQL 18.4 (Debian 18.4-1+b1) on x86_64-pc-linux-gnu, compiled by
x86_64-linux-gnu-gcc (Debian 15.3.0-1) 15.3.0, 64-bit
(1 row)

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 5 Jul 2026 07:53:04 -0700

> x86_64-linux-gnu-gcc (Debian 15.3.0-1) 15.3.0, 64-bit

In addition:

show server_version;
            server_version
------------------------------------
  17.10 (Ubuntu 17.10-1.pgdg24.04+1)

show server_version_num;
  server_version_num
--------------------
  170010

-- 
Adrian Klaver
[email-masked]

---

From: Ron Johnson <[email-masked]>
Date: Sun, 5 Jul 2026 10:56:38 -0400

> local configuration file.

Did you *try* running pg_config?

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: Igor Korot <[email-masked]>
Date: Sun, 5 Jul 2026 13:09:29 -0500

Hi, Rob,

> x86_64-linux-gnu-gcc (Debian 15.3.0-1) 15.3.0, 64-bit
LL,
> See chapter 9.27.11, not Mr. Google.

igor@WaylandGnome ~/dbhandler/Debug/dbhandler $ select version()
bash: syntax error near unexpected token `('

I need to check it inside configure.ac, not inside psql or any other PG client.

Thank you.

---

From: Igor Korot <[email-masked]>
Date: Sun, 5 Jul 2026 13:14:23 -0500

Hi, Adrian,

> > x86_64-linux-gnu-gcc (Debian 15.3.0-1) 15.3.0, 64-bit

Again this is inside psql not inside shell/configure.ac

Thank you.

---

From: Igor Korot <[email-masked]>
Date: Sun, 5 Jul 2026 13:21:18 -0500

Hi, Ron,

On Sun, Jul 5, 2026 at 9:56 AM Ron Johnson <[email-masked]> wrote:
> Did you try running pg_config?

Yes, I did:

igor@WaylandGnome ~/dbhandler $ pg_config --version | sed -e 's#PostgreSQL ##'
16.2

Thank you.

---

From: Brent Wood <[email-masked]>
Date: Sun, 5 Jul 2026 20:20:13 +0000

I might be missing something, but...

You are asking for a shell command - surely

psql -d  ... -c "select version();"

Is a shell command?

But for a non-psql option:

Note that version() is built into the postgres binary itself, if you put the postgres bin folder in your system or user path you can simply run:
postgres -V
postgres (PostgreSQL) 16.14 (Ubuntu 16.14-0ubuntu0.24.04.1)

If it is not in your path, you need to use the full path:
/usr/lib/postgresql/16/bin/postgres -V
postgres (PostgreSQL) 16.14 (Ubuntu 16.14-0ubuntu0.24.04.1)

Easy to wrap in a script (given you want a shell command I figure you want a Linux solution):

#! /bin/bash
# return Postgres version from the command line
CMD=`locate postgresql | grep bin | grep postgres$`
$CMD -V | cut -f 3 -d " "

Eg: with this text in a file called get_ver

bash get_ver
16.14

You can simplify it slightly, but make the script a bit more arcane:

#! /bin/bash
# return Postgres version from the command line

`locate postgresql | grep bin | grep postgres$` -V | cut -f 3 -d " "

Hope this helps...

Brent Wood
________________________________
From: Igor Korot <[email-masked]>
Sent: Monday, 6 July 2026 6:14 am
To: Adrian Klaver <[email-masked]>; pgsql-generallists.postgresql.org <[email-masked]>
Subject: Re: Get version info

Hi, Adrian,

Thank you.

Brent Wood
Principal Technician - GIS and Spatial Data Management
+64-4-386-0529
301 Evans Bay Parade, Greta Point, Hataitai, Wellington, New Zealand
Earth Sciences New Zealand
[Earth Sciences New Zealand]<https://earthsciences.nz>
The Institute of Geological and Nuclear Sciences Limited and the National Institute of Water and Atmospheric Research Limited joined to become the New Zealand Institute for Earth Science Limited. We are known as Earth Sciences New Zealand. For more information on the Earth Sciences transition click here<https://niwa.co.nz/about-niwa/science-sector-reforms>.

Notice: This email and any attachments may contain information which is confidential and/or subject to copyright or legal privilege, and may not be used, published or redistributed without the prior written consent of Earth Sciences New Zealand. If you are not the intended recipient, please immediately notify the sender and delete the email and any attachments. Any opinion or views expressed in this email are those of the individual sender and may not represent those of Earth Sciences New Zealand.

For information about how we process data and monitor communications please see our privacy policy<https://earthsciences.nz/privacy-policy>.

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 5 Jul 2026 13:24:17 -0700

> I need to check it inside configure.ac, not inside psql or any other PG client.

 From configure.ac, for major version:

18
AC_INIT([PostgreSQL], [18.0], [[email-masked]], [], 
[https://www.postgresql.org/])

19beta1
AC_INIT([PostgreSQL], [19beta1], [[email-masked]], [], 
[https://www.postgresql.org/])

Do you need more detail than that?

If so what other Postgres files do you have access to?

---

From: Igor Korot <[email-masked]>
Date: Sun, 5 Jul 2026 16:06:56 -0500

Hi, Brent,

> You are asking for a shell command - surely

Please read the subject line of this thread.

And so in order to test it I can run the command inside the
Terminal/shell...

Thank you.

>
> *psql -d  ... -c "select version();"*
>
> Is a shell command?
>
> Note that version() is built into the postgres binary itself, if you put
> the postgres bin folder in your system or user path you can simply run:
> *postgres -V*
> *postgres (PostgreSQL) 16.14 (Ubuntu 16.14-0ubuntu0.24.04.1)*
>
> */usr/lib/postgresql/16/bin/postgres -V*
> *postgres (PostgreSQL) 16.14 (Ubuntu 16.14-0ubuntu0.24.04.1)*
>
> *CMD=`locate postgresql | grep bin | grep postgres$`*
> *$CMD -V | cut -f 3 -d " "*
>
> *bash get_ver *
> *16.14*
> *#! /bin/bash*
> *# return Postgres version from the command line*
>
> *`locate postgresql | grep bin | grep postgres$` -V | cut -f 3 -d " "*
>
>
> Hope this helps...
>
>
> Brent Wood
> ------------------------------
> *From:* Igor Korot <[email-masked]>
> *Sent:* Monday, 6 July 2026 6:14 am
> *To:* Adrian Klaver <[email-masked]>;
> pgsql-generallists.postgresql.org <[email-masked]>
> *Subject:* Re: Get version info
>
> Hi, Adrian,
>
> *Brent Wood *
>  <https://earthsciences.nz>
> The Institute of Geological and Nuclear Sciences Limited and the National
> Institute of Water and Atmospheric Research Limited joined to become the
> New Zealand Institute for Earth Science Limited. We are known as Earth
> Sciences New Zealand. For more information on the Earth Sciences transition click
> here <https://niwa.co.nz/about-niwa/science-sector-reforms>.
>
> *Notice:* This email and any attachments may contain information which is
> confidential and/or subject to copyright or legal privilege, and may not be
> used, published or redistributed without the prior written consent of Earth
> Sciences New Zealand. If you are not the intended recipient, please
> immediately notify the sender and delete the email and any attachments. Any
> opinion or views expressed in this email are those of the individual sender
> and may not represent those of Earth Sciences New Zealand.
>
> For information about how we process data and monitor communications
> please see our privacy policy <https://earthsciences.nz/privacy-policy>.
>

---

From: Igor Korot <[email-masked]>
Date: Sun, 5 Jul 2026 16:17:09 -0500

Hi, Adrian,

> Do you need more detail than that?

Yes.
How do I find out if its 18 or 19 or 17 or?

Thank you.