Subject: PG Unpivot ?

From: dfgpostgres <[email-masked]>
Date: Mon, 3 Nov 2025 12:18:55 -0500

psql (13.2, server 15.3) on linux

I think they call this "unpivot" in MSSQL ?

How can I get an sql query to return  one line per column with... an ID,
column name and value.  the ctid for the id field is fine.

Example:
dvdb=# create table unpivot (intcol integer, floatcol float, strcol
varchar);
CREATE TABLE
dvdb=# insert into unpivot (intcol,floatcol,strcol) values
(1,1.1,'one'),(2,2.2,'two'),(3,3.3,'three');
INSERT 0 3
dvdb=# select * from unpivot;
 intcol | floatcol | strcol
--------+----------+--------
      1 |      1.1 | one
      2 |      2.2 | two
      3 |      3.3 | three
(3 rows)

I want 9 records returned, each row with 3 cols, 1st col is the ctid,
second is the column name, third is the val.

Thanks in Advance !

---

From: Tom Lane <[email-masked]>
Date: Mon, 03 Nov 2025 12:33:23 -0500

> second is the column name, third is the val.

Perhaps psql's "expanded" mode is close enough?

regression=# \x
Expanded display is on.
regression=# select * from unpivot;
-[ RECORD 1 ]---
intcol   | 1
floatcol | 1.1
strcol   | one
-[ RECORD 2 ]---
intcol   | 2
floatcol | 2.2
strcol   | two
-[ RECORD 3 ]---
intcol   | 3
floatcol | 3.3
strcol   | three

PS: I do not advise relying on ctid as a row identifier.
Use a proper primary key.

			regards, tom lane