Subject: List of encodings

From: Igor Korot <[email-masked]>
Date: Sat, 18 Apr 2026 01:46:16 -0500

Hi, ALL,
Does the list shown in
https://www.postgresql.org/docs/current/multibyte.html#MULTIBYTE-CHARSET-SUPPORTED
stored somewhere in INFORMATION_SCHEMA?

Or is it hard coded inside the PostgreSQL codebase?

Thank you.

---

From: "David G. Johnston" <[email-masked]>
Date: Sat, 18 Apr 2026 00:19:21 -0700

> stored somewhere in INFORMATION_SCHEMA?

This wouldn’t be under the purview of information schema.  You can find
pg-specific pieces though:

https://www.postgresql.org/docs/current/catalog-pg-conversion.html

Note the function used to convert ids to names.

> Or is it hard coded inside the PostgreSQL codebase?

 Yes.  Doesn’t preclude exposing it via SQL but we don’t do so directly.

David J.

---

From: Tom Lane <[email-masked]>
Date: Sat, 18 Apr 2026 11:08:31 -0400

> stored somewhere in INFORMATION_SCHEMA?

No, the SQL standard doesn't specify any such view.

You could try

# select n, pg_encoding_to_char(n) from generate_series(0,50) n;
 n  | pg_encoding_to_char 
----+---------------------
  0 | SQL_ASCII
  1 | EUC_JP
  2 | EUC_CN
  3 | EUC_KR
  4 | EUC_TW
  5 | EUC_JIS_2004
  6 | UTF8
  ...

			regards, tom lane