Subject: After upgrading libpq, the same function(PQftype) call returns a different OID

From: M Tarkeshwar Rao <[email-masked]>
Date: Sat, 15 Mar 2025 18:53:08 +0000

Hi all,

We are using PostgreSQL libpq in our application. The code worked fine for the past four years, but after upgrading the library, the function PQftype is returning unexpected values for some columns.
Specifically, the issue occurs with a column of type timestamp(3) without time zone.

What could be causing this change, and how can we resolve it?"

Postgres Version(upgraded from 11.18 to 13.20)

Example:

Before the libpq Upgrade (Expected Behavior)

Let's say your PostgreSQL database has a table:

CREATE TABLE example (
    id SERIAL PRIMARY KEY,
    filetime TIMESTAMP(3) WITHOUT TIME ZONE
);

In the old version of libpq, calling PQftype on the filetime column returns:

Oid filetime_oid = PQftype(res, 1); // Assuming 'filetime' is at index 1
printf("Filetime column OID: %u\n", filetime_oid);

Expected output (before upgrade):
Filetime column OID: 1114

After the libpq Upgrade (Unexpected Behavior)
After upgrading libpq, the same function call returns a different OID, such as 123456.

What could be the reason?

Regards
Tarkeshwar

---

From: Tom Lane <[email-masked]>
Date: Sat, 15 Mar 2025 15:02:08 -0400

> Specifically, the issue occurs with a column of type timestamp(3) without time zone.

The OID of type timestamp has not changed.  Perhaps you are now
querying some other table.  I'd suggest looking into pg_type to
find out what type is represented by the OID you're now getting,
and then searching pg_attribute to see what's using that.

select typname from pg_type where oid = 123456;

select attrelid::regclass, attname from pg_attribute where atttypid = 123456;

Also, if you really do mean that you changed only libpq and
nothing about the server side, I'd have to guess that you're
connecting to some other database than before.  That would be
surprising, but with zero details it's hard to debug.

			regards, tom lane