Subject: Can't install Postgres version 18

From: Nicolai Madsen <[email-masked]>
Date: Fri, 12 Jun 2026 14:07:44 +0200

Hi

I had installed Postgres version 18 earlier on my PC, but I want to start
over, and remove all of the DB's I have made. I couldn't figure out how to
do that, so I googled and was told that I should uninstall postgres, stop
the service in the task manager, and then delete the folder under
C:/Program Files. AFter that I should restart the PC, and everything should
be gone, and ready to be reinstalled. I did that, but each time I am trying
to reinstall it, then it doesn't make any folders under Program Files, so
the service can't be started. It just give me this warning

If I try to reinstall it again, it tells me that it is already installed,
and asks me if I want to make a change, repair, or uninstallation. I have
tried to choose that it should install the docs also, and then it creates
the folder under program files, but it only contains the docs nothing else.

I have tried to restart the PC, reinstall it and tried google how to solve
this but no solution yet.

I hope you could guide me the right way.

-- 
Hilsen

Nicolai Friis Madsen

---

From: Adrian Klaver <[email-masked]>
Date: Fri, 12 Jun 2026 07:27:19 -0700

On 6/12/26 5:07 AM, Nicolai Madsen wrote:
> Hi
> 
> I had installed Postgres version 18 earlier on my PC, but I want to 
> start over, and remove all of the DB's I have made. I couldn't figure 
> out how to do that, so I googled and was told that I should uninstall 
> postgres, stop the service in the task manager, and then delete the 
> folder under C:/Program Files. AFter that I should restart the PC, and 
> everything should be gone, and ready to be reinstalled. I did that, but 
> each time I am trying to reinstall it, then it doesn't make any folders 
> under Program Files, so the service can't be started. It just give me 
> this warning
> 
> image.png
> If I try to reinstall it again, it tells me that it is already 
> installed, and asks me if I want to make a change, repair, or 
> uninstallation. I have tried to choose that it should install the docs 
> also, and then it creates the folder under program files, but it only 
> contains the docs nothing else.
> 
> I have tried to restart the PC, reinstall it and tried google how to 
> solve this but no solution yet.
> 

1) Assuming you are using the EDB  installer did you follow the 
instructions here?:

https://www.enterprisedb.com/docs/supported-open-source/postgresql/uninstalling/

2) Did you try the repair option on the reinstall?

-- 
Adrian Klaver
[email-masked]

---

From: Nicolai <[email-masked]>
Date: Fri, 12 Jun 2026 18:59:50 +0200

Hi

I did not use the edb to remove it, I used the installer file and then select remove. After that I delete the whole folder under c:/program file. Then a restart of the pc.

I have tried repair many times

Hilsen

Nicolai Friis

> Den 12. jun. 2026 kl. 16.27 skrev Adrian Klaver <[email-masked]>:
> 
>> I had installed Postgres version 18 earlier on my PC, but I want to start over, and remove all of the DB's I have made. I couldn't figure out how to do that, so I googled and was told that I should uninstall postgres, stop the service in the task manager, and then delete the folder under C:/Program Files. AFter that I should restart the PC, and everything should be gone, and ready to be reinstalled. I did that, but each time I am trying to reinstall it, then it doesn't make any folders under Program Files, so the service can't be started. It just give me this warning
>> image.png
>> If I try to reinstall it again, it tells me that it is already installed, and asks me if I want to make a change, repair, or uninstallation. I have tried to choose that it should install the docs also, and then it creates the folder under program files, but it only contains the docs nothing else.
>> I have tried to restart the PC, reinstall it and tried google how to solve this but no solution yet.
> 1) Assuming you are using the EDB  installer did you follow the instructions here?:
>

---

From: Adrian Klaver <[email-masked]>
Date: Fri, 12 Jun 2026 10:10:27 -0700

> I did not use the edb to remove it, I used the installer file and then select remove. After that I delete the whole folder under c:/program file. Then a restart of the pc.

1) Confirm that you actually installed using the EDB installer.

2) Did you actually read the information at the link?

3) I'm going to say "I delete the whole folder under c:/program file." 
is not helping.

---

From: Adrian Klaver <[email-masked]>
Date: Fri, 12 Jun 2026 14:14:47 -0700

> I have tried repair many times

Starting fresh(no Postgres install) on a Windows 10 machine I did:

1) Download EDB installer for Postgres 18.4.

2) Ran installer.

3) Verified server was running via pgAdmin4.

4) To uninstall followed instructions from here:

5) Ran installer again and verified server was running.

Not sure what the issue is you are having, though I suspect an 
incomplete install that has has left stuff behind in the Registry.

I would suggest raising an issue an here:

https://github.com/EnterpriseDB/edb-installers/issues

 From your original post:

'... remove all of the DB's I have made'

Unless this was some very large number I would think it would be easier 
to just DROP DATABASE each one, then going through an uninstall/install 
cycle.

---

From: Jan Karremans <[email-masked]>
Date: Sun, 14 Jun 2026 12:12:52 +0200

I would simply recommend not to run Postgres on Windows. You are mixing two distinctly different approaches to IT-systems. In that sense Linux is so much more akin to the world Postgres lives in.

Cheers,
Jan

Verstuurd vanaf mijn iPhone

> Op 13 jun 2026 om 23:23 heeft Nicolai <[email-masked]> het volgende geschreven:
> 
> Hi
>

---

From: Anthony DeBarros <[email-masked]>
Date: Mon, 15 Jun 2026 07:45:11 -0500

Hello,

On Jun 14, 2026 at 6:12:52 AM, Jan Karremans <[email-masked]> wrote:

> I would simply recommend not to run Postgres on Windows. You are mixing
> two distinctly different approaches to IT-systems. In that sense Linux is
> so much more akin to the world Postgres lives in.
>
> Cheers,
> Jan
>
>
>
Absolutely true. However, it’s good that EDB has provided a Windows
installer for PostgreSQL because nearly 2/3 of personal computer users run
Windows, and many, many people who are setting out to learn database
programming run on it.

That said, I have two observations, both related to experiences as author
of a book about learning SQL:

   1. I have installed and uninstalled PostgreSQL and pgAdmin on Windows
   dozens of times and had no issues at all as long as I used the official
   installer/uninstaller. However, the uninstaller does not completely remove
   all traces of the application, so for a fully clean uninstall you must
   remove registry entries, delete left-behind application directories, etc.

   2. Using PostgreSQL under Windows is far more complicated than running
   it on macOS, where you can install PostgresApp and get up and running in
   just minutes with very little to fiddle with. And that app is getting
   better all the time with support for Postgres extensions. I steer everyone
   towards Macs these days.

Cheers,

Anthony DeBarros

---

From: Arbol One <[email-masked]>
Date: Mon, 15 Jun 2026 13:01:29 +0000

I would also strongly recommend Linux over MacOS or WinOS. Having said that, I have also uninstalled PosgreSQL on my WinOS machine, so I find your advice proper and accurate.

Verily, with every difficulty there is relief (94:6)
________________________________
From: Anthony DeBarros <[email-masked]>
Sent: June 15, 2026 8:45 AM
To: [email-masked] <[email-masked]>
Subject: Re: Can't install Postgres version 18

Hello,

On Jun 14, 2026 at 6:12:52 AM, Jan Karremans <[email-masked]<mailto:[email-masked]>> wrote:
I would simply recommend not to run Postgres on Windows. You are mixing two distinctly different approaches to IT-systems. In that sense Linux is so much more akin to the world Postgres lives in.

Cheers,
Jan

Absolutely true. However, it’s good that EDB has provided a Windows installer for PostgreSQL because nearly 2/3 of personal computer users run Windows, and many, many people who are setting out to learn database programming run on it.

That said, I have two observations, both related to experiences as author of a book about learning SQL:

  1.  I have installed and uninstalled PostgreSQL and pgAdmin on Windows dozens of times and had no issues at all as long as I used the official installer/uninstaller. However, the uninstaller does not completely remove all traces of the application, so for a fully clean uninstall you must remove registry entries, delete left-behind application directories, etc.

  2.  Using PostgreSQL under Windows is far more complicated than running it on macOS, where you can install PostgresApp and get up and running in just minutes with very little to fiddle with. And that app is getting better all the time with support for Postgres extensions. I steer everyone towards Macs these days.

Cheers,

Anthony DeBarros

---

From: Nick Canale <[email-masked]>
Date: Mon, 15 Jun 2026 09:11:34 -0400

I would recommend either installing it on WSL or through docker or both. If
you're not familiar with WSL or docker this would be a great opportunity to
learn about them!

On Mon, Jun 15, 2026 at 9:01 AM Arbol One <[email-masked]> wrote:

> I would also strongly recommend Linux over MacOS or WinOS. Having said
> that, I have also uninstalled PosgreSQL on my WinOS machine, so I find your
> advice proper and accurate.
>
> ------------------------------
> *From:* Anthony DeBarros <[email-masked]>
> *Sent:* June 15, 2026 8:45 AM
> *To:* [email-masked] <[email-masked]>
> *Subject:* Re: Can't install Postgres version 18
>
> Hello,
>