Subject: PostgreSQL 15.9 Update: Partitioned tables with foreign key constraints

From: Paul Foerster <[email-masked]>
Date: Tue, 19 Nov 2024 17:11:22 +0100

Hi,

the PostgreSQL 15.9 release notes instruct to look out for especially detached partitions with foreign key constraints. I'm in the process of updating our databases from 15.8 to 15.9 now and found a case where the select statement returns a constraint.

The release notes say nothing about when to fix that using the generated add or drop statements.

Do I want/need to do that before or after I exchange the software? And if it is to be done on a particular of the two releases, why is that?

https://www.postgresql.org/docs/15/release-15-9.html
Section E.1.2, changelog entry 5.

Any insight would be highly appreciated. Thanks in advance.

Cheers
Paul

---

From: Tom Lane <[email-masked]>
Date: Tue, 19 Nov 2024 11:25:02 -0500

> The release notes say nothing about when to fix that using the generated add or drop statements.

Generally speaking, our release notes are addressed to someone who's
already installed the update (or a later one).

			regards, tom lane