Subject: Re: Extract only maximum date from column

From: Rich Shepard <[email-masked]>
Date: Thu, 4 Dec 2025 12:13:49 -0800 (PST)

On Thu, 4 Dec 2025, Bryan Sayer wrote:

> I believe in general you need
>
> having c.next_contact = max(c.next_contact)
>
> (at least in ANSI SQL) Use having for after the join has occurred

Bryan,

Postgresql didn't like that regardless of where I inserted the `having'
stanza.

Thanks,

Rich

---

From: Bryan Sayer <[email-masked]>
Date: Thu, 4 Dec 2025 15:24:40 -0500

You don't include the where clause, just the having clause after the 
group by.

At least that is what I remember. But it has been awhile.

*Bryan Sayer*
Retired Demographer/Statistician
/In a world in which you can be anything, *be kind*/