Subject: Re: Cannot drop column

From: "David G. Johnston" <[email-masked]>
Date: Wed, 18 Dec 2024 11:49:56 -0700

On Wed, Dec 18, 2024 at 11:47 AM Rich Shepard <[email-masked]>
wrote:

> I'm not seeing why postgres won't drop a table's column:
>
> bustrac=# select * from statustypes order by stat_name;
>       stat_name
> --------------------
>   Client
>   Lead
>   No further contact
>   Opportunity
>   Proposal submitted
>   Prospect
>   Qualified
>   Referral
>   Suspect
> (9 rows)
>
> bustrac=# alter table statustypes drop column Suspect;
> ERROR:  column "suspect" of relation "statustypes" does not exist
> bustrac=#
>
> What have I done incorrectly?
>

Failed to double-quote your column name.

David J.

---

From: Rich Shepard <[email-masked]>
Date: Wed, 18 Dec 2024 11:05:31 -0800 (PST)

> Failed to double-quote your column name.

David,

Thanks. That's a new one on me.

Regards,

Rich