Subject: Re: Transaction issue

From: Rich Shepard <[email-masked]>
Date: Thu, 20 Jun 2024 07:47:55 -0700 (PDT)

On Thu, 20 Jun 2024, Rob Sargent wrote:

> Is psql running in emacs (which is my preferred sql shell. M-x sql-postgres)?

Rob,

Not when I'm entering new data or updating existing tables. Otherwise, yes.

Regards,

Rich

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 20 Jun 2024 07:56:28 -0700

> Not when I'm entering new data or updating existing tables. Otherwise, yes.

 From one of my previous posts(modified):

At this point I think you need to create a simple test case where:

1) You have script with
BEGIN;
<A line that contains the syntax error>
COMMIT; --optional

2) In psql do \i <the_script>

3) Do what you did before to 'recover' from the error.

Shows us the content of the steps in your reply.

-- 
Adrian Klaver
[email-masked]

---

From: Rich Shepard <[email-masked]>
Date: Thu, 20 Jun 2024 08:30:00 -0700 (PDT)

> Shows us the content of the steps in your reply.

Adrian,

I belive that I did this yesterday. Regardless, either leaving off `BEGIN;'
from the top of the script, or entering it prior to running the script,
resolves the issue.

I've not seen a problem since finding the solutions.

Best regards,

Rich