Subject: HISTIGNORE in psql

From: Wiwwo Staff <[email-masked]>
Date: Tue, 18 Jun 2024 06:45:15 +0000

Hi!
As a big history lover, it would be great to have the HISTIGNORE
functionality added to psql.

Have a great day!
Wiwwo

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 18 Jun 2024 09:12:17 -0700

> functionality added to psql.

HISTIGNORE is a BASH feature and psql runs in more then the BASH shell.

Do you mean you would like a clone of that feature added to psql?

Also psql uses either readline or libedit so it would need to work with 
those.

-- 
Adrian Klaver
[email-masked]

---

From: Wiwwo Staff <[email-masked]>
Date: Tue, 18 Jun 2024 17:28:41 +0000

Hi Adrian,
yes, of course, that is what I meant: being able to tell psql to exclude
some patterns from being stored in the .psql_history file

---

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 18 Jun 2024 21:03:27 +0200

> On 18 Jun 2024, at 19:28, Wiwwo Staff <[email-masked]> wrote:

> being able to tell psql to exclude some patterns from being stored in the .psql_history file

Off the cuff that sounds like a pretty useful thing to have.

--
Daniel Gustafsson