Subject: RE: Offline PostgreSQL installation: what are the rpm packages to install ?

From: COURTAULT Francois <[email-masked]>
Date: Mon, 18 Aug 2025 17:07:08 +0000

THALES GROUP LIMITED DISTRIBUTION to email recipients

Hello again,

I haven't find any documentation describing the way to install PostgreSQL using  a list of RPM packages to apply !

Best Regards.

From: COURTAULT Francois <[email-masked]>
Sent: lundi 18 août 2025 18:55
To: [email-masked]
Subject: Offline PostgreSQL installation: what are the rpm packages to install ?

THALES GROUP LIMITED DISTRIBUTION to email recipients

Hello everyone,

I want to install PostgreSQL 17.6 on a machine (Redhat 9) not connect to Internet?
What are the minimum rpm packages to install ?

Nest Regards.

---

From: Tom Lane <[email-masked]>
Date: Mon, 18 Aug 2025 13:39:36 -0400

> I haven't find any documentation describing the way to install PostgreSQL using  a list of RPM packages to apply !

The core project wouldn't document that, because we just ship source
code not RPMs.  There might be a README in the core postgresql RPM
package telling you what's what.

			regards, tom lane

---

From: COURTAULT Francois <[email-masked]>
Date: Tue, 19 Aug 2025 10:09:12 +0000

Hello Ruben,

I think you have understood my needs. I wanted to know which rpm packages I have to install for PostgreSQL 17.6.
The problem is that the command provided at https://stormatics.tech/blogs/offline-postgresql-installation-on-rhel-9-solving-the-no-internet-challenge : sudo
yum deplist postgresql17-server doesn’t work on Redhat 8.10 ☹

Do you have the equivalent command of yum deplist for Redhat 8.10 ?

Best Regards.

From: Ruben Morais <[email-masked]>
Sent: lundi 18 août 2025 19:14
To: COURTAULT Francois <[email-masked]>
Subject: Re: Offline PostgreSQL installation: what are the rpm packages to install ?

Hi,

Just read from postgres documentation:

https://www.postgresql.org/download/linux/redhat/

They put a repo in end of page , where you can download.

If you do a search in google , will find another post:

https://stormatics.tech/blogs/offline-postgresql-installation-on-rhel-9-solving-the-no-internet-challenge

Rúben Morais

On Mon, Aug 18, 2025, 18:07 COURTAULT Francois <[email-masked]<mailto:[email-masked]>> wrote:

Hello again,

I haven’t find any documentation describing the way to install PostgreSQL using  a list of RPM packages to apply !

Best Regards.

From: COURTAULT Francois <[email-masked]<mailto:[email-masked]>>
Sent: lundi 18 août 2025 18:55
To: [email-masked]<mailto:[email-masked]>
Subject: Offline PostgreSQL installation: what are the rpm packages to install ?

Hello everyone,

Nest Regards.