Subject: Re: Corruption of few tables

From: "[email-masked]" <[email-masked]>
Date: Wed, 26 Feb 2025 06:33:07 +0000 (UTC)

Thanks
// Following is the PB code to retrieve data
ls_pack_version = fn_get_product_version()ls_pack_build   = fn_get_product_build()
Select releasenumber, buildnumber Into   :ls_db_version, :ls_db_build From   public.co_version Where  modulename = 'ALL';  If SQLCA.sqlcode <> 0 Then    ls_db_version = ''    ls_db_build   = 'base'End If
If ls_pack_version <> ls_db_version Then   as_msg   = 'Version do not match.~r~nDB Ver : ' + ls_db_version   as_msg += '      Build : ' + ls_db_build   as_msg += '~r~nPack.Ver : ' + ls_pack_version   as_msg += '      Build : ' + ls_pack_build   as_msg += '~r~nPlease upgrade Program or Database'   Messagebox('Error' as_msg)   Return FalseEnd If
We get the above message [ Version do not match .... ], as SQLCA.Sqlcode returned is not ZERO.  [ Successful read will return ZERO ]
We tried selecting tables from PGAdmin also, where we got Disconnected from the Server...  error message.
    On Tuesday 25 February, 2025 at 07:02:40 pm IST, Greg Sabino Mullane <[email-masked]> wrote:  
 
 On Tue, Feb 25, 2025 at 7:03 AM [email-masked] <[email-masked]> wrote:
1.  Why is corruption happening?  How to find out the reason?

It sounds more like user error than actual corruption, but without more data we cannot determine. Show us the exact commands you ran, along with the results you expected to see, and the results you got. Provide as much detail as possible. A reproducible test case would be ideal.

Happiness Always

That is an excellent valediction, thanks for that.
Cheers,Greg
--Crunchy Data - https://www.crunchydata.comEnterprise Postgres Software Products & Tech Support

---

From: Adrian Klaver <[email-masked]>
Date: Wed, 26 Feb 2025 08:07:05 -0800

On 2/25/25 22:33, [email-masked] wrote:
> Select releasenumber, buildnumber
> Into   :ls_db_version, :ls_db_build
> From   public.co_version
> Where  modulename = 'ALL';
> If SQLCA.sqlcode <> 0 Then
>      ls_db_version = ''
>      ls_db_build   = 'base'
> End If
> 
> If ls_pack_version <> ls_db_version Then
>     as_msg   = 'Version do not match.~r~nDB Ver : ' + ls_db_version
>     as_msg += '      Build : ' + ls_db_build
>     as_msg += '~r~nPack.Ver : ' + ls_pack_version
>     as_msg += '      Build : ' + ls_pack_build
>     as_msg += '~r~nPlease upgrade Program or Database'
>     Messagebox('Error' as_msg)
>     Return False
> End If
> 
> We get the above message [ Version do not match .... ], as SQLCA.Sqlcode 
> returned is not ZERO.  [ Successful read will return ZERO ]

Not sure how the two are connected.

The message is generated if:

ls_pack_version <> ls_db_version.

 From what I can see that depends on the results of:

ls_pack_version = fn_get_product_version()

and

Select releasenumber ...

as well as

If SQLCA.sqlcode <> 0

How do you what is actually leading to?:

ls_pack_version <> ls_db_version.

> On Tue, Feb 25, 2025 at 7:03 AM [email-masked] 
> <mailto:[email-masked]> <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> It sounds more like user error than actual corruption, but without more 
> data we cannot determine. Show us the exact commands you ran, along with 
> the results you expected to see, and the results you got. Provide as 
> much detail as possible. A reproducible test case would be ideal.
> 
>     Happiness Always
> 
> 
> Cheers,
> Greg
> --
> Crunchy Data - https://www.crunchydata.com <https://www.crunchydata.com>
> Enterprise Postgres Software Products & Tech Support
> 

-- 
Adrian Klaver
[email-masked]