Subject: Re: Left join syntax error

From: Rich Shepard <[email-masked]>
Date: Sat, 18 May 2024 08:04:13 -0700 (PDT)

On Sat, 18 May 2024, Adrian Klaver wrote:

> ... LEFT JOIN companies as c ON c.company_nbr = p.company_nbr;

Adrian,

Tried that:
bustrac-# LEFT JOIN companies as c ON c.company_nbr = p.company_nbr;
ERROR:  table name "c" specified more than once

Thanks,

Rich

---

From: Adrian Klaver <[email-masked]>
Date: Sat, 18 May 2024 08:12:00 -0700

> ERROR:  table name "c" specified more than once

Show the complete query.

Take the error message as correct, you are specifying 'companies as c' 
more then once.

-- 
Adrian Klaver
[email-masked]

---

From: Rich Shepard <[email-masked]>
Date: Sat, 18 May 2024 08:41:26 -0700 (PDT)

On Sat, 18 May 2024, Adrian Klaver wrote:

> Show the complete query.
> Take the error message as correct, you are specifying 'companies as c' more 
> then once.

Adrian,

I saw that but didn't know how to specify the alias only one time.

Thanks,

Rich