Subject: Re: glibc updarte 2.31 to 2.38

From: Adrian Klaver <[email-masked]>
Date: Thu, 19 Sep 2024 08:00:52 -0700

On 9/19/24 07:37, Paul Foerster wrote:
> Hi,
> 
> we have SLES 15.5 which has glibc 2.31. Our admin told us that he's about to install the SLES 15.6 update which contains glibc 2.38.
> 
> I have built our PostgreSQL software from source on SLES 15.5, because we have some special requirements which the packages cannot fulfill. So I have questions:
> 
> 1) Do I have to build it again on 15.6?
> 
> 2) Does the glibc update have any impact? I recall having to have everything reindexed when the 2.28 update came due to major locale changes, but I didn't have to do it since then.
> 
> 3) Where and how can I find out if it is necessary to reindex? And how can I find out what indexes would be affected.
> 
> I'd really appreciate your comments. Thanks very much in advance.

I would take a look at:

https://wiki.postgresql.org/wiki/Locale_data_changes

It refers to the glibc 2.8 change in particular, but includes some 
generic tips that could prove useful.

The glibc change log below might also be useful:

https://sourceware.org/glibc/wiki/Release

> Paul

-- 
Adrian Klaver
[email-masked]

---

From: Paul Foerster <[email-masked]>
Date: Thu, 19 Sep 2024 19:51:52 +0200

Hi Adrian,

> On 19 Sep 2024, at 17:00, Adrian Klaver <[email-masked]> wrote:
> 
> I would take a look at:
> 
> It refers to the glibc 2.8 change in particular, but includes some generic tips that could prove useful.
> 
> 

I've seen those before but since the article only refers to 2.28 and SUSE 15.3, and I couldn't find anything in the glibc release notes, I thought I'd ask.

Cheers,
Paul