Subject: Table Description!!

From: Fariba Noorbakhsh <[email-masked]>
Date: Wed, 04 Jul 2001 15:53:39 +0200

Hi everybody,

I want to have a description for tables in my DB(Postgresql DB).
Is there any way to put description of tables in Postgresql DB or not?!

Thanks in Advance,
Fariba

---

From: Colin Taylor <[email-masked]>
Date: Thu, 5 Jul 2001 08:08:55 +0100

You could use the "COMMENT" command.
Something like:
COMMENT ON TABLE <table name> IS '<comment>';

HTH,
Colin

> -----Original Message-----
> From: Fariba Noorbakhsh [mailto:[email-masked]]
> Sent: Wednesday, 04 July 2001 14:54
> To: [email-masked]
> Subject: [GENERAL] Table Description!!
> 
> 
> Hi everybody,
> 
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 5: Have you checked our extensive FAQ?
> 
> http://www.postgresql.org/users-lounge/docs/faq.html
> 

**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager. [email-masked]

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.

www.mimesweeper.com
**********************************************************************

---

From: Colin Taylor <[email-masked]>
Date: Thu, 5 Jul 2001 14:29:43 +0100

Check out http://www.postgresql.org/idocs/index.php?sql-comment.html.
I got my knowledge from the PostgreSQL: Introduction and Concepts book.
HTH,
Colin

> From: omid omoomi [mailto:[email-masked]]
> Sent: Thursday, 05 July 2001 14:22
> To: [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [GENERAL] Table Description!!
> 
> 
> Hi,
> I couldn't find such a thing.
> May be better if having a copy from pg_tables and add a 
> description column 
> to that:
> 
> Create table foo as Select * from pg_tables;
> Alter table foo add col descript text ;
> 
> HTH
> Omid
> 
> >From: Colin Taylor <[email-masked]>
> >To: "'Fariba Noorbakhsh'" <[email-masked]>,   
> >[email-masked]
> >Subject: RE: [GENERAL] Table Description!!
> >Date: Thu, 5 Jul 2001 08:08:55 +0100
> >
> ______________________________________________________________
> ___________
> Get Your Private, Free E-mail from MSN Hotmail at 
http://www.hotmail.com.

www.mimesweeper.com