Subject: pg_dump problems

From: "[email-masked]" <[email-masked]>
Date: Fri, 09 Dec 2005 12:21:25 +0100

Hi !

We have an old web service with a pgsql database (in Suse Linux). This 
database created by another programmer who no accessible now.

We want to dump this database to get data from it. But I have no passwords.

I do many things, but I cannot create dump from this database.
I know the name of database (inventory), and from zope I see this 
connection parameters: "dbname=inventory users=zope". And from zope that 
is working good.

When I try to make pg_dump:

    pg_dump -s -v -U zope -W inventory >/invdump

it prompt for pwd, and I get auth. error.

When I try to create dump with def. user:
    pg_dump -s -v -W inventory >/invdump

It is show error that "root user doesn't exists".

So: how to I dump this database ? Or how to I transfer it to a Windows 
machine to make dump on it ?

Is anybody have a solution ?

Thanks for advance: dd

---

From: "A. Kretschmer" <[email-masked]>
Date: Fri, 9 Dec 2005 15:40:44 +0100

> We want to dump this database to get data from it. But I have no passwords.

Change the trust-level in pg_hba.conf to:
local   all         all                               trust

Reload the config. Now you can login (local) without password.

For more Info:
http://www.postgresql.org/docs/8.1/interactive/client-authentication.html

HTH, Andreas
-- 
Andreas Kretschmer    (Kontakt: siehe Header)
Heynitz:  035242/47212,      D1: 0160/7141639
GnuPG-ID 0x3FFF606C http://wwwkeys.de.pgp.net
 ===    Schollglas Unternehmensgruppe    ===