Subject: Re: Two sequences associated with one identity column

From: "Colin 't Hart" <[email-masked]>
Date: Thu, 30 Oct 2025 09:55:12 +0100

relname          | relnamespace | relpersistence
--------------------------+--------------+----------------
 <sequence1>  |    524799410 | p
 <sequence2>  |    524799410 | p
(2 rows)

On Wed, 29 Oct 2025 at 17:28, Adrian Klaver <[email-masked]> wrote:
>
> On 10/29/25 06:40, Colin 't Hart wrote:
> > As expected the dump contains:
> >
> > CREATE TABLE <schema>.<tablename> (
> > <other columns>,
> >      id bigint NOT NULL
> > );
> >
> > <snip>
> >
> > --
> > -- Name: <sequence1>; Type: SEQUENCE; Schema: <schema>; Owner: <owner>
> > --
> >
> > ALTER TABLE <schema>.<tablename> ALTER COLUMN id ADD GENERATED ALWAYS
> > AS IDENTITY (
> >      SEQUENCE NAME <schema>.<sequence1>
> >      START WITH 1
> >      INCREMENT BY 1
> >      NO MINVALUE
> >      NO MAXVALUE
> >      CACHE 1
> > );
> >
> >
> > --
> > -- Name: <sequence2>; Type: SEQUENCE; Schema: <schema>; Owner: <owner>
> > --
> >
> > ALTER TABLE <schema>.<tablename> ALTER COLUMN id ADD GENERATED ALWAYS
> > AS IDENTITY (
> >      SEQUENCE NAME <schema>.<sequence2>
> >      START WITH 1
> >      INCREMENT BY 1
> >      NO MINVALUE
> >      NO MAXVALUE
> >      CACHE 1
> > );
>
> Just a wild guess. Assuming <schema> is the same, what is the output of:
>
> SELECT
>      relname,
>      relnamespace,
>      relpersistence
> FROM
>      pg_class
> WHERE
>      relname IN ('<sequence1>', '<sequence2> ')
>      AND relnamespace = '<schema>'::regnamespace;
>
>
> >
>
> > /Colin
> >
>
> --
> Adrian Klaver
> [email-masked]

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 30 Oct 2025 07:42:26 -0700

On 10/30/25 01:55, Colin 't Hart wrote:
> --------------------------+--------------+----------------o

Well so much for that guess. I was exploring the idea that the sequence 
may have been unlogged at some point and you had both a logged(p) and 
unlogged(u) instance of each.