Subject: 回复：searching for libpq5-14.1-42PGDG.rhel8.x86_64

From: 王瞿 <[email-masked]>
Date: Mon, 12 Aug 2024 12:54:04 +0800 (GMT+08:00)

It returned “Access Denied” when I access the archive repo.
Did I miss sonething？
​

Thanks.
| |
[email-masked]
|
|
邮箱：[email-masked]
|
---- 回复的原邮件 ----
| 发件人 | Ron Johnson<[email-masked]> |
| 日期 | 2024年08月12日 12:01 |
| 收件人 | pgsql-general<[email-masked]> |
| 抄送至 | |
| 主题 | Re: Re: searching for libpq5-14.1-42PGDG.rhel8.x86_64 |
On Sat, Aug 10, 2024 at 5:45 AM 王瞿 <[email-masked]> wrote:

Hi Laurenz Albe

Thank you!

>The client libraries for this version are in
>https://download.postgresql.org/pub/repos/yum/14/redhat/rhel-8-x86_64/postgresql14-14.1-1PGDG.rhel8.x86_64.rpm

But My project was specified to use the package libpq5-14.1-42PGDG.rhel8.x86_64.rpm.

There are only later versions of packages in the yum repo like this：

https://download.postgresql.org/pub/repos/yum/common/redhat/rhel-8-x86_64/libpq5-15.1-42PGDG.rhel8.x86_64.rpm

You might be able to find something here: https://yum.postgresql.org/repopackages/#pgredhatoldrepos

Better, though, to explain that 14.1 is not available anymore.

--

Death to America, and butter sauce.
Iraq lobster!

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 13 Aug 2024 00:13:44 +0300

Hi,

> It returned “Access Denied” when I access the archive repo.

As I responded you on our issue tracker, old packages for libpq5 is not
available. I also provided you solutions:

https://redmine.postgresql.org/issues/8025#note-1

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR