Subject: Re: Removing terminal period from varchar string in table column

From: Jeff Ross <[email-masked]>
Date: Tue, 15 Jul 2025 11:43:17 -0600

On 7/15/25 11:30, Rich Shepard wrote:

> I want to remove the terminal period '.' from the varchar strings in the
> 'company_name' column in all rows with that period in the companies 
> table.
>
> I've looked at trim(), translate(), "substr(company_name 1,
> length(compan_name) - 1)", and a couple of other functions and am 
> unsure how
> best to do this without corrupting the database table.
>
> Advice needed.
>
> TIA,
>
> Rich
>
>
>
How about

test:

     select company_name, replace(company_name,'.','') from companies;

update:

     update companies set company_name = replace(company_name,'.','') 
where company_name like '%.';

?

Jeff

---

From: Rich Shepard <[email-masked]>
Date: Tue, 15 Jul 2025 11:02:14 -0700 (PDT)

On Tue, 15 Jul 2025, Jeff Ross wrote:

>     update companies set company_name = replace(company_name,'.','') where 
> company_name like '%.';

Jeff,

These contain the table and column names I didn't see in web page examples.
Using update looks better to me.

Many thanks,

Rich