Subject: Re: load fom csv

From: Andy Hartman <[email-masked]>
Date: Tue, 17 Sep 2024 11:13:02 -0400

Still when I try to run from my powershell script it hangs...

On Tue, Sep 17, 2024 at 8:31 AM Andy Hartman <[email-masked]>
wrote:

> I have bad data in an Int field...
>
>  Thanks for your help.
>
> On Tue, Sep 17, 2024 at 1:55 AM Muhammad Usman Khan <[email-masked]>
> wrote:
>
>> Hi,
>> Try the following options:
>>
>>
>>    - Check if psql is working independently:
>>    psql -h $pgServer -d $pgDatabase -U $pgUser -c "SELECT 1;"
>>    - Check for permission issues on the CSV file
>>    - Run the command manually without variables
>>    psql -h your_host -d your_db -U your_user -c "\COPY your_table FROM
>>    'C:/path/to/your/file.csv' DELIMITER ',' CSV HEADER;"
>>    - set a timeout using the PGCONNECT_TIMEOUT environment variable:
>>    $env:PGCONNECT_TIMEOUT=30
>>
>>
>>
>> On Mon, 16 Sept 2024 at 20:35, Andy Hartman <[email-masked]>
>> wrote:
>>
>>> I'm trying to run this piece of code from Powershell and it just sits
>>> there and never comes back. There are only 131 records in the csv.
>>>
>>> $connectionString =
>>> "Host=$pgServer;Database=$pgDatabase;Username=$pgUser;Password=$pgPassword"
>>> $copyCommand = "\COPY $pgTable FROM '$csvPath' DELIMITER ',' CSV HEADER;"
>>>
>>> psql -h $pgServer -d $pgDatabase -U $pgUser -c $copyCommand
>>>
>>>
>>> how can I debug this?
>>>
>>> Table layout
>>>
>>>
>>

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 17 Sep 2024 08:23:29 -0700

> Still when I try to run from my powershell script it hangs...

And the Postgres log shows?

-- 
Adrian Klaver
[email-masked]