Subject: Re: Selecting all variations of job title in a list

From: Adrian Klaver <[email-masked]>
Date: Tue, 25 Nov 2025 12:46:37 -0800

On 11/25/25 11:08, Rich Shepard wrote:
> On Tue, 25 Nov 2025, Adrian Klaver wrote:
> 
>> Something like?:
>>
>> select 'Env mgr.' ilike  ANY(ARRAY['Asst Gen Mgr.', 'Env Mgr.', 'Gen 
>> Mgr.', 'Mgr.','Plant Mgr.']);
> 
> Adrian,
> 
> Hadn't thought of this.
> 
> Your, and Ron's, answers taught me that the answer to my question is 'no,
> there is no shortcut.' :-)

You will need to be clearer about what you want.

If it is to fetch titles with Mgr in the name then it would be simple:

select * from people_table where title ilike '%mgr%';

If it is something more selective you will need to provide a more 
detailed example.

> Thanks,
> Rich

-- 
Adrian Klaver
[email-masked]

---

From: Rich Shepard <[email-masked]>
Date: Tue, 25 Nov 2025 12:53:12 -0800 (PST)

On Tue, 25 Nov 2025, Adrian Klaver wrote:

> If it is something more selective you will need to provide a more detailed 
> example.

Adrian,

I thought my example was clear: there are modifiers to job titles such as
'Manager,' 'Vice President,' 'Engineer.' That's why I asked if the
`like/ilike' modifier would work in a list passed to the `in' command.

Rich

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 25 Nov 2025 12:58:58 -0800

> `like/ilike' modifier would work in a list passed to the `in' command.

So what are you searching on, the title, the modifier or both?