Subject: CONST :consttype relpartbound pg_class

From: Дмитрий <[email-masked]>
Date: Wed, 23 Oct 2024 17:07:34 +0300

Hello Evryone!
 
Can anyone tell me what this means  « CONST :consttype 1184 » или « CONST :consttype 23 » relpartbound   pg _ class ?
I'm interested in what 1184 and 23 mean, and what other meanings they could have? Where can I read about this?
 
select pt.relpartbound
from pg_class base_tb join pg_inherits i on i.inhparent = base_tb.oid join pg_class pt on pt.oid = i.inhrelid
WHERE pt.relpartbound like '%PARTITIONRANGEDATUM%';
 
{PARTITIONBOUNDSPEC :strategy r :is_default false :modulus 0 :remainder 0 :listdatums <> :lowerdatums ({PARTITIONRANGEDATUM :kind 0 :value {CONST :consttype 1184 :consttypmod -1 :constcollid 0 :constlen 8 :constbyval true :constisnull false :location 113 :constvalue 8 [ 0 -76 -57 -34 -54 -56 2 0 ]} :location 113}) :upperdatums ({PARTITIONRANGEDATUM :kind 0 :value {CONST :consttype 1184 :consttypmod -1 :constcollid 0 :constlen 8 :constbyval true :constisnull false :location 131 :constvalue 8 [ 0 -12 4 94 38 -53 2 0 ]} :location 131}) :location 107}
 
{PARTITIONBOUNDSPEC :strategy r :is_default false :modulus 0 :remainder 0 :listdatums <> :lowerdatums ({PARTITIONRANGEDATUM :kind 0 :value {CONST :consttype 23 :consttypmod -1 :constcollid 0 :constlen 4 :constbyval true :constisnull false :location 112 :constvalue 4 [ 0 0 0 0 0 0 0 0 ]} :location 112}) :upperdatums ({PARTITIONRANGEDATUM :kind 0 :value {CONST :consttype 23 :consttypmod -1 :constcollid 0 :constlen 4 :constbyval true :constisnull false :location 119 :constvalue 4 [ 1 0 0 0 0 0 0 0 ]} :location 119}) :location 106}
 
Thank you.

---

From: Laurenz Albe <[email-masked]>
Date: Wed, 23 Oct 2024 18:44:02 +0300

On Wed, 2024-10-23 at 17:07 +0300, Дмитрий wrote:
> Can anyone tell me what this means «CONST :consttype 1184» или «CONST :consttype 23» relpartbound pg_class?

That looks like a parsed PostgreSQL expression.

Those are constants of data type 1184 (timestamp with time zone) and 23 (text).

Yours,
Laurenz Albe