Subject: REFRESH MATERIALIZED VIEW CONCURRENTLY is blocking autovacuum on table

From: Dirk Krautschick <[email-masked]>
Date: Mon, 9 Feb 2026 02:17:59 +0100

Hi,

I have a situation here where a frequent

REFRESH MATERIALIZED VIEW CONCURRENTLY

is preventing autovacuum on some tables kind of running into a circle of 
growing.

Why is this acutally blocking autovacuum and what is the best practice 
to prevent
this excelt just not refreshing the materialized view frequently? :-)

Cheers

Dirk

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 8 Feb 2026 17:41:47 -0800

> is preventing autovacuum on some tables kind of running into a circle of 

You will need to:

1) Show the original CREATE MATERIALIZED VIEW command.

2) Indicate if the blocked autovacuum is on the tables the view is 
pulling from or other tables.

3) Tell us the Postgres version and whether it is community version or a 
fork.

-- 
Adrian Klaver
[email-masked]

---

From: Laurenz Albe <[email-masked]>
Date: Mon, 09 Feb 2026 12:11:37 +0100

On Mon, 2026-02-09 at 02:17 +0100, Dirk Krautschick wrote:
> is preventing autovacuum on some tables kind of running into a circle of growing.

I'm not sure I understand you correctly.

REFRESH MATERIALIZED VIEW CONCURRENTLY will block VACUUM on the materialized
view, because the statements take conflicting locks.

But the statement won't block VACUUM on the underlying tables.
However, if REFRESH MATERIALIZED VIEW CONCURRENTLY is running for a long time,
you will have a long-running transaction, and VACUUM won't be able to clean
up tuples that became dead later.

> Why is this acutally blocking autovacuum and what is the best practice to prevent 

I also have trouble understanding that sentence.

Yours,
Laurenz Albe