Subject: dblink Future support vs FDW

From: Dhritman Roy <[email-masked]>
Date: Thu, 27 Jun 2024 15:32:13 +0000

Hello,

This is my attempt to seek support at PostGreSQL.
So, if I have broken any protocols/rules or violated any code of conduct then please do forgive and guide me. Thanks.

My organization is building something which is using dblink and what we are building shall take several months and then to be offered to a client.
I just wanted to check what is the future/roadmap of dblink?
Is it going to be obsolete/removed from PostGreSQL in upcoming versions?

I know we can use FDW but our teams are right now considering dblink ( it seems it is more performant when compared to FDW ) and we obviously do not want to end up in a situation where we develop something in few months and then we find that the PostGreSQL support is ending with a new version.

Any information/pointers related to future of dblink will be very useful for us and highly appreciated.

Regards
ROY.

________________________________
The information transmitted herein is intended only for the person or entity to which it is addressed and may contain confidential, proprietary and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from any computer.

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 27 Jun 2024 10:08:10 -0700

On 6/27/24 08:32, Dhritman Roy wrote:
> I know we can use FDW but our teams are right now considering dblink ( 
> it seems it is more performant when compared to FDW ) and we obviously 
> do not want to end up in a situation where we develop something in few 
> months and then we find that the PostGreSQL support is ending with a new 
> version.

I would say that is highly unlikely. Even if it where to happen at some 
point in the distant future you still have:

https://git.postgresql.org/gitweb/?p=postgresql.git;a=tree;f=contrib/dblink;h=03de20165973a346e2ce8e3c7fdfb11448487dd6;hb=HEAD

Open source code under a permissive license that you could keep running 
with.

> ------------------------------------------------------------------------
> The information transmitted herein is intended only for the person or 
> entity to which it is addressed and may contain confidential, 
> proprietary and/or privileged material. Any review, retransmission, 
> dissemination or other use of, or taking of any action in reliance upon, 
> this information by persons or entities other than the intended 
> recipient is prohibited. If you received this in error, please contact 
> the sender and delete the material from any computer.
> 

-- 
Adrian Klaver
[email-masked]