Subject: Re: Postgres do not support tinyint?

From: Igor Korot <[email-masked]>
Date: Wed, 8 Jan 2025 00:26:32 -0600

Hi, Ron,

On Tue, Jan 7, 2025 at 11:24 PM Ron Johnson <[email-masked]> wrote:
>
> On Wed, Jan 8, 2025 at 12:06 AM Igor Korot <[email-masked]> wrote:
>>
>> Hi, ALL,
>> According to https://www.postgresql.org/docs/9.1/datatype-numeric.html, the
>> smallest numeric type supports numbers from -32768 to 32767/
>>
>> My data will be in a range of [0..4], and so I guess my DB table will waste
>> space, right?
>
>
> 1. It's not 1994 anymore, when 8M rows was enormous.
> 2. Record structures are padded by word size, so tinyint wouldn't matter unless you specifically ordered the fixed width columns from largest to smallest size when creating the table.
> 3. The "bit" type might serve your needs.

 I don't see the "bit" field here:
https://www.postgresql.org/docs/current/datatype-numeric.html...

Thank you..

>
> --
> Death to <Redacted>, and butter sauce.
> Don't boil me, I'm still alive.
> <Redacted> lobster!

---

From: Christophe Pettus <[email-masked]>
Date: Tue, 7 Jan 2025 22:28:14 -0800

> On Jan 7, 2025, at 22:26, Igor Korot <[email-masked]> wrote:

https://www.postgresql.org/docs/current/datatype-bit.html