Subject: [help] Error in database import

From: Tu Ho <[email-masked]>
Date: Fri, 19 Apr 2024 20:58:25 -0700

Hi,

I am currently having a project where I need to combine 2 large database. I
was not however able to import an excel file .csv into the database. The
error was ERROR: syntax error at or near "OIDS" LINE 1: ...ing Site" ,
"International Name(s)" ) FROM STDIN OIDS DELI...
^"

I have no idea how to fix this because I used the "upload file"
option. What should I do?

---

From: Adrian Klaver <[email-masked]>
Date: Fri, 19 Apr 2024 21:27:41 -0700

On 4/19/24 20:58, Tu Ho wrote:
> Hi,
> 
> I am currently having a project where I need to combine 2 large 
> database. I was not however able to import an excel file .csv into the 

There are Excel files(.xls/.xlsx) and there are *.csv files.

> database. The error was ERROR: syntax error at or near "OIDS" LINE 1: 
> ...ing Site" , "International Name(s)" ) FROM STDIN OIDS DELI...
> ^"
> 

Use a recent version of whatever client you are using as:

https://www.postgresql.org/docs/current/sql-copy.html

"If 1, OIDs are included in the data; if 0, not. Oid system columns are 
not supported in PostgreSQL anymore, but the format still contains the 
indicator."

Your client is using old syntax as the last version of Postgres that 
allowed  FROM STDIN OIDS was:

https://www.postgresql.org/docs/11/sql-copy.html

"where option can be one of:

     FORMAT format_name
     OIDS [ boolean ]
"

And Postgres 11 is ~6 months past EOL.

-- 
Adrian Klaver
[email-masked]