Subject: Re: old OS

From: Tom Lane <[email-masked]>
Date: Tue, 04 Feb 2025 13:00:45 -0500

Christophe Pettus <[email-masked]> writes:
> On Feb 4, 2025, at 09:49, Marc Millas <[email-masked]> wrote:
>> My question is: is there any possibility to find something ?
>> and/or what is the latest psql available on a redhat 6.5 ?

> Although I've not done so, it should be possible to build from source even on a system that old.

Another workaround is to connect from a remote instance of psql.
You'd probably need to modify the server's pg_hba.conf and perhaps
poke a hole in its firewall, but that's still easier than installing
new software.

			regards, tom lane

---

From: Marc Millas <[email-masked]>
Date: Tue, 4 Feb 2025 21:27:52 +0100

Hi Tom,

the data in the redhat 6.5 machine is NOT in Postgres, its in an old Oracle
instance, 4TB of it.
So I am working on  a way to extract it to a file or, better to a pipe.
If I was able to get a local psql then, fine, i'll pipe the flow to it,
done.(almost...)

If no local postgres tool, as said, I will try to pipe data through the
network,
but this imply that data will be put exactly as psql, on the new machine,
will be able to 'ingest' it.
easy for most things, somewhat more boring for blobs...

Marc MILLAS
Senior Architect
+33607850334
www.mokadb.com

---

From: Tom Lane <[email-masked]>
Date: Tue, 04 Feb 2025 15:34:50 -0500

> will be able to 'ingest' it.

I'm not really following why this requires any processing to be done
locally on the old machine.  You've got to shove the data over the
network sooner or later, so why not sooner?

			regards, tom lane

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 4 Feb 2025 12:58:24 -0800

On 2/4/25 12:27, Marc Millas wrote:
> Hi Tom,
> 
> the data in the redhat 6.5 machine is NOT in Postgres, its in an old 
> Oracle instance, 4TB of it.

Maybe?:

https://github.com/laurenz/oracle_fdw

-- 
Adrian Klaver
[email-masked]

---

From: Ron Johnson <[email-masked]>
Date: Tue, 4 Feb 2025 16:12:49 -0500

https://ora2pg.darold.net/

It can access remote Oracle databases, and migrate LOB columns to bytea.
Worked quite well for me on a database 3x that size.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!