Subject: Re: Purpose of pg_dump tar archive format?

From: Ron Johnson <[email-masked]>
Date: Tue, 4 Jun 2024 11:25:05 -0400

On Tue, Jun 4, 2024 at 10:43 AM Adrian Klaver <[email-masked]>
wrote:

> On 6/4/24 05:13, Ron Johnson wrote:
> > It doesn't support compression nor restore reordering like the custom
> > format, so I'm having trouble seeing why it still exists (at least
> > without a doc warning that it's obsolete).
>
> pg_dump -d test -U postgres -Ft  | gzip --stdout > test.tgz
>

Who's got meaningful databases that small anymore?

And if you've got meaningfully sized databases, open port 5432 and move
them using pg_dump.

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 4 Jun 2024 08:33:47 -0700

On 6/4/24 08:25, Ron Johnson wrote:
> On Tue, Jun 4, 2024 at 10:43 AM Adrian Klaver <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 

If you don't need the tar format then don't use it.

-- 
Adrian Klaver
[email-masked]