Subject: Re: Using Expanded Objects other than Arrays from plpgsql

From: Andrey Borodin <[email-masked]>
Date: Tue, 4 Feb 2025 00:15:02 +0500

> On 3 Feb 2025, at 23:18, Tom Lane <[email-masked]> wrote:
> 
> But I don't want to think of
> EEOP_PARAM_CALLBACK as being specifically tied to PL/pgSQL.

I've found 1 users on Github [0]. And a lot of copied code like [1]. And there might be some unindexed cases.
Let's keep paramarg2.

Best regards, Andrey Borodin.
[0] https://github.com/wanglinn/xadb/blob/7695b7edcb0a89f3173b648c0da5b953538f2aa9/src/backend/pgxc/pool/execRemote.c#L835
[1] https://github.com/babelfish-for-postgresql/babelfish_extensions/blob/376cf488804fa02f9b1db5bbfbe74e98627fe96c/contrib/babelfishpg_tsql/src/pl_exec.c#L8030

---

From: Tom Lane <[email-masked]>
Date: Thu, 06 Feb 2025 16:05:02 -0500

> I've found 1 users on Github [0]. And a lot of copied code like [1]. And there might be some unindexed cases.

Yeah, sounds like the best path if there are already outside users
of paramarg.

Do you have any further comments on this patch?

			regards, tom lane

---

From: Andrey Borodin <[email-masked]>
Date: Fri, 7 Feb 2025 15:40:44 +0500

> On 7 Feb 2025, at 02:05, Tom Lane <[email-masked]> wrote:
> 

No, all steps of the patch set look good to me.

---

From: Tom Lane <[email-masked]>
Date: Tue, 11 Feb 2025 12:50:14 -0500

> No, all steps of the patch set look good to me.

Pushed then.  Thanks for reviewing!

			regards, tom lane

---

From: Pavel Borisov <[email-masked]>
Date: Thu, 13 Feb 2025 17:02:18 +0400

> Pushed then.  Thanks for reviewing!
Thanks to Michel and everyone working on the patch!

Regards,
Pavel Borisov