Subject: rookie question about upgrade from 13 to 17

From: Martin Mueller <[email-masked]>
Date: Tue, 25 Feb 2025 22:51:35 +0000

I would like to update my current version of Postgres13 on a Mac mini to the latest version, but I can’ t find anything in the general document that explains the procedure in terms readily understand by retired professors of English…

I understand that there are three items involved:

  1.  The installed instance of version 13
  2.  The not yet installed instance of version 17
  3.  The tables (several hundred and adding up to 30 GB when  backed  with pg_dump)

I also understand that there is a pg_upgrade command that picks up the old tables and presents them to the later version in a somewhat different format

But I don’t understand how the different steps in the upgrade process interact. What are the steps and in what order  that wil

  1.  Install version 17
  2.  Upgrade the data so that they will in version 17
  3.  Get rid of the no longer needed version 13

There is a Postgres app for the Mac, but upgrading from one version  to another doesn’t seem to be part of it.

I use postgres exclusively in a single user fashion with a GUI front end, as if it were a more powerful version of Microsoft Access.

I’ll gladly volunteer to write up the process in English intelligible to others like me, and there may be some.

With thanks in advance

Martin Mueller
Professor emeritus of English and Classics
Northwestern University

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 25 Feb 2025 15:24:17 -0800

On 2/25/25 14:51, Martin Mueller wrote:
> I would like to update my current version of Postgres13 on a Mac mini to 
> the latest version, but I can’ t find anything in the general document 
> that explains the procedure in terms readily understand by retired 
> professors of English…
> 

Probably the easiest way is using pg_dump/pg_restore.

> 
> I also understand that there is a pg_upgrade command that picks up the 
> old tables and presents them to the later version in a somewhat 
> different format
> 
> But I don’t understand how the different steps in the upgrade process 
> interact. What are the steps and in what order  that wil
> 
>  1. Install version 17

Are you referring to ?:

https://postgresapp.com/documentation/

> 
> I use postgres exclusively in a single user fashion with a GUI front 
> end, as if it were a more powerful version of Microsoft Access.
> 

-- 
Adrian Klaver
[email-masked]