Subject: Pipeline Mode vs Single Row Mode / Chunked Rows Mode

From: Daniel Frey <[email-masked]>
Date: Thu, 19 Dec 2024 15:36:49 +0100

Hi,

I'm adding support for Pipeline Mode to my C++ PostgreSQL client library (https://github.com/taocpp/taopq) and I tried to understand the interaction between Pipeline Mode and Single Row Mode / Chunked Rows Mode. It seems that it works sometimes, but I don't get the feeling that it was deliberately designed to work consistently. Example:

* Consider a table with three rows of data
* I send two (identical) SELECT commands, e.g. "SELECT * FROM test_table"
* I call PQpipelineSync()
* I call PQsetSingleRowMode()
* I read the results, I get
  * One result with size 1
  * Another one with size 1
  * Another one with size 1
  * A final one with size 0 for the first select
  * A result with size 3 for the second select
  * A result with PGRES_PIPELINE_SYNC

When I try to call PQsetSingleRowMode() for the second SELECT, it fails.
It also seems weird that I can call it for the first result after the sync call, but maybe that's OK?

Anyway, is there some documentation about how these modes interact and how they can be combined? Or should they never be combined?

-Daniel

---

From: Dominique Devienne <[email-masked]>
Date: Thu, 2 Jan 2025 09:48:42 +0100

On Thu, Dec 19, 2024 at 3:37 PM Daniel Frey <[email-masked]> wrote:
> I'm adding support for Pipeline Mode to my C++ PostgreSQL client library [...]

Hi. Happy New Year. I was interested in that question as well, having
played with Pipeline mode a bit, but not Single Row mode yet. Any
insights? --DD

---

From: "Daniel Verite" <[email-masked]>
Date: Mon, 06 Jan 2025 20:47:38 +0100

Daniel Frey wrote:

> I tried to understand the interaction between Pipeline Mode and
> Single Row Mode / Chunked Rows Mode. It seems that it works
> sometimes, but I don't get the feeling that it was deliberately
> designed to work consistently

It's supposed to work, and there are regression tests in
src/test/modules/libpq_pipeline/libpq_pipeline.c [1]
that exercise the single row mode and PQpipelineSync().

You might want to compare your code workflow with how it's done in
that file, and maybe submit a bug report with your test case if the
conclusion is that your code should not error out.

[1]
https://git.postgresql.org/gitweb/?p=postgresql.git;a=blob;f=src/test/modules/libpq_pipeline/libpq_pipeline.c

Best regards,
-- 
Daniel Vérité
https://postgresql.verite.pro/
Twitter: @DanielVerite

---

From: Daniel Frey <[email-masked]>
Date: Tue, 7 Jan 2025 16:28:37 +0100

> On 6. Jan 2025, at 20:47, Daniel Verite <[email-masked]> wrote:
> 
> Daniel Frey wrote:
> 

Thank you for the link, I will need some time to investigate and to figure out what is different.

Best, Daniel