Subject: Re: What happens if the socket lock file is deleted?

From: Tom Lane <[email-masked]>
Date: Thu, 29 Jan 2026 16:24:39 -0500

Adrian Klaver <[email-masked]> writes:
>  From here at ~line 1781:

> https://github.com/postgres/postgres/blob/master/src/backend/postmaster/postmaster.c

>         /*
>          * Once a minute, verify that postmaster.pid hasn't been removed or
>          * overwritten.  If it has, we force a shutdown.

Actually, Steve was asking about socket lock files, so the relevant
code fragment is the bit just below that:

        /*
         * Touch Unix socket and lock files every 58 minutes, to ensure that
         * they are not removed by overzealous /tmp-cleaning tasks.  We assume
         * no one runs cleaners with cutoff times of less than an hour ...
         */
        if (now - last_touch_time >= 58 * SECS_PER_MINUTE)
        {
            TouchSocketFiles();
            TouchSocketLockFiles();
            last_touch_time = now;
        }

			regards, tom lane

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 29 Jan 2026 16:14:28 -0800

> code fragment is the bit just below that:

Aah, I was close but no cigar.

Well at least I learned something.

-- 
Adrian Klaver
[email-masked]