Subject: PGDG PostgreSQL Debian package: Question on conditions for creation of new cluster

From: Schmid Andreas <[email-masked]>
Date: Wed, 19 Feb 2025 08:45:53 +0000

Hi

I'm trying to install the postgresql-17 Debian package from PGDG apt repo alongside an already existing PostgreSQL 16 installation. So there is already a PostgreSQL 16 cluster on my machine (which I want to upgrade to version 17 using the pg_upgrade command later on).

If I'm not wrong, the PostgreSQL packages used to automatically create a new cluster during installation, even if there already was an older cluster present. (Using a different port in this case.) But this doesn't happen with the 17.3 package. Does anyone know if this behavior has changed? Or anyone can explain on which conditions a new cluster is created and when not?

There was a now closed discussion on this topic on Stack Overflow: https://stackoverflow.com/questions/79441161/postgres-17-3-installation-no-longer-creates-a-new-cluster. Of course, I will create the additional cluster using pg_createcluster if this is the way to go. The point is that I'm installing PostgreSQL using an Ansible script, and pg_createcluster was not needed until now. So before I update my script, I hope to get some more information about the behavior of the PostgreSQL packages regarding automatic cluster creation.

Thanks a lot,
Andy

---

From: Laurenz Albe <[email-masked]>
Date: Wed, 19 Feb 2025 10:50:27 +0100

On Wed, 2025-02-19 at 08:45 +0000, Schmid Andreas wrote:
> I'm trying to install the postgresql-17 Debian package from PGDG apt repo
> alongside an already existing PostgreSQL 16 installation. So there is
> already a PostgreSQL 16 cluster on my machine (which I want to upgrade
> to version 17 using the pg_upgrade command later on).
> 
> If I'm not wrong, the PostgreSQL packages used to automatically create a
> new cluster during installation, even if there already was an older
> cluster present. (Using a different port in this case.) But this doesn't
> happen with the 17.3 package. Does anyone know if this behavior has
> changed? Or anyone can explain on which conditions a new cluster is
> created and when not?
> 
> There was a now closed discussion on this topic on Stack Overflow:
> https://stackoverflow.com/questions/79441161/postgres-17-3-installation-no-longer-creates-a-new-cluster
> Of course, I will create the additional cluster using pg_createcluster
> if this is the way to go. The point is that I'm installing PostgreSQL
> using an Ansible script, and pg_createcluster was not needed until now.
> So before I update my script, I hope to get some more information about
> the behavior of the PostgreSQL packages regarding automatic cluster creation.

I just tried on an Ubuntu system (I think that the packages are pretty
much the same), and installing 17.3 created a cluster.
I think the Stackoverflow question was about installing 17.3 if v17
is already installed.  In that case, no new cluster is created.

Yours,
Laurenz Albe

-- 

*E-Mail Disclaimer*
Der Inhalt dieser E-Mail ist ausschliesslich fuer den 
bezeichneten Adressaten bestimmt. Wenn Sie nicht der vorgesehene Adressat 
dieser E-Mail oder dessen Vertreter sein sollten, so beachten Sie bitte, 
dass jede Form der Kenntnisnahme, Veroeffentlichung, Vervielfaeltigung oder 
Weitergabe des Inhalts dieser E-Mail unzulaessig ist. Wir bitten Sie, sich 
in diesem Fall mit dem Absender der E-Mail in Verbindung zu setzen.

*CONFIDENTIALITY NOTICE & DISCLAIMER
*This message and any attachment are 
confidential and may be privileged or otherwise protected from disclosure 
and solely for the use of the person(s) or entity to whom it is intended. 
If you have received this message in error and are not the intended 
recipient, please notify the sender immediately and delete this message and 
any attachment from your system. If you are not the intended recipient, be 
advised that any use of this message is prohibited and may be unlawful, and 
you must not copy this message or attachment or disclose the contents to 
any other person.