Subject: Re: Issue with date/timezone conversion function

From: Lok P <[email-masked]>
Date: Tue, 9 Apr 2024 21:46:35 +0530

On Tue, Apr 9, 2024 at 9:26 PM Adrian Klaver <[email-masked]>
wrote:

> On 4/9/24 08:43, Lok P wrote:
> > Hi All,
> > It's version 15.4 of postgresql database. Every "date/time" data type
> > attribute gets stored in the database in UTC timezone only. One of the
> > support persons local timezone is "asia/kolkata" and  that support
> > person needs to fetch the count of transactions from a table-
> > transaction_tab and share it with another person/customer who is in the
> > EST timezone, so basically the transaction has to be shown or displayed
> > the EST timezone.
>
> What is the datatype for the create_timestamp?
>
> What does SHOW timezone; return on the server?
>
>
>
Thank you for the quick response.

The column data type for "create_timestamp" is "timestamptz'.
Show timezone from the support users client machine UI showing
"Asia/Calcutta".
Not having access to run "Show timezone" on the server currently, I will
try to get it.
output from pg_setting showing setting as "Asia/Calcutta', reset_val as
"Asia/Calcutta", boot_val as "GMT"

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 9 Apr 2024 09:58:34 -0700

On 4/9/24 9:16 AM, Lok P wrote:
> 
> On Tue, Apr 9, 2024 at 9:26 PM Adrian Klaver <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 

In the pg_settings query what are the source, sourcefile, sourceline 
fields set to?

-- 
Adrian Klaver
[email-masked]