Subject: Re: Regarding fillfactor use case for only delete ops

From: Laurenz Albe <[email-masked]>
Date: Sat, 07 Jun 2025 13:53:14 +0200

On Fri, 2025-06-06 at 09:59 -0400, Ron Johnson wrote:
> On Fri, Jun 6, 2025 at 8:57 AM Laurenz Albe <[email-masked]> wrote:
> > On Fri, 2025-06-06 at 14:10 +0530, Durgamahesh Manne wrote:
> > > Can we generate a fill factor for tables that have delete ops ?
> > > 
> > > Does the fill factor really work and help to minimize the bloat for tables that have delete ops?
> > > 
> > > I have parent table with weekly partitions So for every week 50 to 60 gb of bloat generates and autovacuum params already in place for child tables 
> > 
> > Nothing can ever avoid bloat caused by DELETE, except partitioning in a
> > way that you can drop a partition rather than running DELETE.
> 
> Isn't the fill factor aimed at reducing bloat during updates of HOT tables?

Yes, but not during DELETEs.

HOT updates also don't directly avoid bloat on tables; only on indexes.
They reduce the bloat on tables inderectly, because the dead tuples can
be cleaned up with less effort.

Yours,
Laurenz Albe

---

From: Ron Johnson <[email-masked]>
Date: Sat, 7 Jun 2025 14:42:38 -0400

On Sat, Jun 7, 2025 at 7:53 AM Laurenz Albe <[email-masked]>
wrote:

> > > > I have parent table with weekly partitions So for every week 50 to
> 60 gb of bloat generates and autovacuum params already in place for child
> tables
> > >

I still don't understand why OP is deleting from a date-partitioned table,
instead of dropping the oldest partitions.

> be cleaned up with less effort.

Thanks for the clarification.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!