Subject: Re: Windows installation problem at post-install step

From: Ertan Küçükoglu <[email-masked]>
Date: Mon, 22 Jul 2024 21:48:50 +0300

Adrian Klaver <[email-masked]>, 22 Tem 2024 Pzt, 21:10 tarihinde
şunu yazdı:

> I am getting out of my depth here, but I am pretty sure that:
>
> ENCODING = 'UTF8' LOCALE_PROVIDER = libc LOCALE = 'Turkish_Turkey.1254'
>
> is not going to work. That you will need to change the locale to a
> Turkish UTF8 name.
>

I added tr_TR.UTF-8 to the system locales.
I also changed all Turkish_Turkey.1254 to tr_TR.UTF-8 in the dump file.
Unfortunately, I found that there are some databases created using WIN1254
encoding.
I do not know what I should do with them. I don't think simply changing
WIN1254 -> UTF8 will work.
I will probably wait for a working Windows installer.

Thanks & Regards,
Ertan

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 22 Jul 2024 12:56:39 -0700

On 7/22/24 11:48, Ertan Küçükoglu wrote:
> Adrian Klaver <[email-masked] 
> <mailto:[email-masked]>>, 22 Tem 2024 Pzt, 21:10 tarihinde 
> şunu yazdı:
> 
> Unfortunately, I found that there are some databases created using 
> WIN1254 encoding.

 From previous post of yours:

"I was also hit by that OS update.
There is a Microsoft tool for creating a locale installer
https://www.microsoft.com/en-us/download/details.aspx?id=41158
Using that tool and adding a second locale Turkish_Turkey.1254 (name before
Microsoft update) in the OS can fix your broken PostgreSQL.
I believe most people simply choose this path.
There are also several blogs/articles written in Turkish about the problem."

Why not use that?

-- 
Adrian Klaver
[email-masked]