Subject: Re: Row level security policy

From: Laurenz Albe <[email-masked]>
Date: Thu, 14 Nov 2024 10:57:38 +0100

On Wed, 2024-11-13 at 17:33 -0800, Mark Phillips wrote:
> Given a database table with one policy statement FOR SELECT applied, it is necessary
> to apply additional policy statements for insert, update, and delete operations?
> 
> My testing indicates that this is case but I haven’t found an explanation of this
> requirement in the documentation.

https://www.postgresql.org/docs/current/ddl-rowsecurity.html says:

  When row security is enabled on a table (with ALTER TABLE ... ENABLE ROW LEVEL SECURITY),
  all normal access to the table for selecting rows or modifying rows must be allowed by
  a row security policy.

So if you only have a policy for SELECT, that's all you are allowed to do.

Yours,
Laurenz Albe

---

From: Mark Phillips <[email-masked]>
Date: Thu, 14 Nov 2024 04:04:00 -0800

Thank you for clarifying this. I missed that even though it is there in the second paragraph.
 - Mark, out and about.

> On Nov 14, 2024, at 1:57 AM, Laurenz Albe <[email-masked]> wrote:
>