Subject: Re: How to pass a list of locations (longitude, latitude) to a PostgreSQL/PostGIS stored function?

From: Christoph Berg <[email-masked]>
Date: Tue, 25 Mar 2025 18:58:40 +0100

Re: Tom Lane
> You might be best advised to create a composite
> type like "location (long bigint, lat bigint)" and use an array of
> that.

Or use the geometry types from PostGIS, since you are probably going
to do geo lookups on these points anyway.

Christoph

---

From: Thiemo Kellner <[email-masked]>
Date: Tue, 25 Mar 2025 21:21:34 +0100

> to do geo lookups on these points anyway.
Why is pure SQL not an option instead of a procedure/function?